Read the docs
TI-2026-30393 Aliases CVE-2026-42005GHSA-27xg-fw4v-jgv6

Insufficient input validation of internal web server

Priority LOW 21CWE-400Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-400.

Summary

An attacker can send a web request that causes unlimited memory allocation in the internal web server, leading to a denial of service. The internal web server is disabled by default.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00625 50th percentileScored 2026-11-07
Fix Fixed Authoritative (PowerDNS): 4.9.16, 5.0.6, 5.1.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PowerDNSAuthoritative4.9.0 to before 4.9.16; 5.0.0 to before 5.0.6; 5.1.0 to before 5.1.24.9.16, 5.0.6, 5.1.2Patch availableCNA
  • Authoritative VendorPowerDNS Affected 4.9.0 to before 4.9.16; 5.0.0 to before 5.0.6; 5.1.0 to before 5.1.2 Fixed in 4.9.16, 5.0.6, 5.1.2 Patch available CNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:powerdns:authoritative:*:*:*:*:*:*:*:*——PowerDNS
  • cpe:2.3:a:powerdns:authoritative:*:*:*:*:*:*:*:* Versions — — ·PowerDNS

Remediation

  • Fix · CNA Authoritative (PowerDNS) Fixed in 4.9.16, 5.0.6, 5.1.2

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-42005
  2. 2026-10-03 Alias added: GHSA-27xg-fw4v-jgv6
  3. 2026-10-31 EPSS moved to the 50th–90th percentile
  4. 2026-11-01 EPSS moved to the below the 50th percentile
  5. 2026-11-03 EPSS moved to the 50th–90th percentile

References

  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2015-01678 The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and… CVSS 2.0HIGH 7.8
  • TI-2021-14878 PowerDNS Authoritative Server 4.5.0 before 4.5.1 allows anybody to crash the process by… CVSS 3.1HIGH 7.5
  • TI-2016-04703 PowerDNS (aka pdns) Authoritative Server before 3.4.10 does not properly handle a . CVSS 3.0HIGH 7.5
  • TI-2018-12065 Out-of-bounds read in [UNKNOWN] pdns-recursor CVSS 3.0HIGH 7.5
See all 130 →

Sources