Read the docs
TI-2026-30687 Aliases CVE-2026-42387GHSA-9v36-5rhx-cq6m

Insufficient input validation in ZoneToCache

Priority LOW 27CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA.

Summary

A malicious authoritative server can send a crafted zone via the ZoneToCache function that leads to a crash of the Recursor due to insuffcient input validation.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00483 41st percentileScored 2026-11-07
Fix Fixed Recursor (PowerDNS): 5.2.11, 5.3.8, 5.4.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PowerDNSRecursor5.2.0 to before 5.2.11; 5.3.0 to before 5.3.8; 5.4.0 to before 5.4.35.2.11, 5.3.8, 5.4.3Patch availableCNA
  • Recursor VendorPowerDNS Affected 5.2.0 to before 5.2.11; 5.3.0 to before 5.3.8; 5.4.0 to before 5.4.3 Fixed in 5.2.11, 5.3.8, 5.4.3 Patch available CNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:powerdns:recursor:*:*:*:*:*:*:*:*——PowerDNS
  • cpe:2.3:a:powerdns:recursor:*:*:*:*:*:*:*:* Versions — — ·PowerDNS

Remediation

  • Fix · CNA Recursor (PowerDNS) Fixed in 5.2.11, 5.3.8, 5.4.3

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    PowerDNS Recursor 5.2.11, 5.3.8, 5.4.3

    5 records Highest priority Priority LOW 5 LOW

    Other records, highest priority first

    • TI-2026-25994 ZoneToCache can poison the cachePriority LOW 32
    • TI-2026-28855 Information about ECS zero scoped answers might leak to clients that use a specific ECSPriority LOW 30
    • TI-2026-37815 Spoofed answers can mark an authoritative non-EDNS capablePriority LOW 27

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-42387
  2. 2026-10-03 Alias added: GHSA-9v36-5rhx-cq6m

References

  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2015-01678 The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and… CVSS 2.0HIGH 7.8
  • TI-2021-14878 PowerDNS Authoritative Server 4.5.0 before 4.5.1 allows anybody to crash the process by… CVSS 3.1HIGH 7.5
  • TI-2016-04703 PowerDNS (aka pdns) Authoritative Server before 3.4.10 does not properly handle a . CVSS 3.0HIGH 7.5
  • TI-2018-12065 Out-of-bounds read in [UNKNOWN] pdns-recursor CVSS 3.0HIGH 7.5
See all 130 →

Sources