WordPress TheGem theme Elements (for Elementor) plugin < 5.12.1.1 - Cross Site Scripting (XSS) vulnerability
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CodexThemes TheGem Theme Elements (for Elementor) allows DOM-Based XSS.This issue affects TheGem Theme Elements (for Elementor): from n/a before 5.12.1.1.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00127 2nd percentileScored 2026-11-07
Fix Fixed TheGem Theme Elements (for Elementor) (CodexThemes): 5.12.1.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| CodexThemes | TheGem Theme Elements (for Elementor) | before 5.12.1.1 | 5.12.1.1 | Patch available | CNA |
- TheGem Theme Elements (for Elementor) VendorCodexThemes Affected before 5.12.1.1 Fixed in 5.12.1.1 Patch available CNA
Remediation
- Fix · CNA TheGem Theme Elements (for Elementor) (CodexThemes) Fixed in 5.12.1.1
Timeline
- 2026-10-02 Threatist record created from CVE-2026-42410
- 2026-10-03 Alias added: GHSA-xvp9-96q2-hp9x
More CodexThemes vulnerabilities
- TI-2026-47280 WordPress TheGem (Elementor) theme <= 5.12.3 - SQL Injection vulnerability CVSS 3.1CRITICAL 9.3
- TI-2025-03846 TheGem <= 5.10.3 - Authenticated (Subscriber+) Arbitrary File Upload CVSS 3.1HIGH 8.8
- TI-2025-38368 WordPress TheGem Theme Elements (for WPBakery) plugin <= 5.10.5.1 - Local File Inclusion vulnerability CVSS 3.1HIGH 8.1
- TI-2026-41626 WordPress TheGem Theme Elements (for Elementor) plugin < 5.12.1.1 - Local File Inclusion vulnerability CVSS 3.1HIGH 7.5
- TI-2025-42799 WordPress TheGem Theme Elements (for Elementor) plugin <= 5.11.0 - Local File Inclusion vulnerability CVSS 3.1HIGH 7.5
- TI-2025-42081 WordPress TheGem Theme Elements (for Elementor) plugin <= 5.10.5.1 - Local File Inclusion vulnerability CVSS 3.1HIGH 7.5
Sources
- CVE-2026-42410 · CVE Program
- CVE-2026-42410 · NVD
- FIRST EPSS
- GHSA-xvp9-96q2-hp9x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences