NGINX Open-Source ngx_http_v3_module vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-416 and the CVSS impact.
Summary
NGINX Open Source has a vulnerability in the ngx_http_v3_module module. When NGINX Open Source is configured to use the HTTP/3 QUIC module, a remote unauthenticated attacker along with conditions beyond their control can use a specially crafted HTTP/3 session to reopen a QPACK encoder stream. This may cause a Use-after-Free in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| F5 | NGINX Open Source | 1.31.0 to before 1.31.2 | 1.31.2 | Patch available | CNA |
- NGINX Open Source VendorF5 Affected 1.31.0 to before 1.31.2 Fixed in 1.31.2 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:f5:nginx_gateway_fabric:*:*:*:*:*:*:*:* | 1.3.0 – 1.6.2; 2.0.0 to before 2.6.4 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_ingress_controller:*:*:*:*:*:*:*:* | 3.5.0 – 3.7.2; 5.0.0 to before 5.5.1 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_ingress_controller:4.0.0:*:*:*:*:*:*:* | 4.0.0 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_ingress_controller:4.0.1:*:*:*:*:*:*:* | 4.0.1 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_instance_manager:*:*:*:*:*:*:*:* | 2.17.0 – 2.22.0 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_open_source:*:*:*:*:*:*:*:* | 1.31.0 to before 1.31.2 | Vulnerable | F5 |
- cpe:2.3:a:f5:nginx_gateway_fabric:*:*:*:*:*:*:*:* Versions 1.3.0 – 1.6.2; 2.0.0 to before 2.6.4 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_ingress_controller:*:*:*:*:*:*:*:* Versions 3.5.0 – 3.7.2; 5.0.0 to before 5.5.1 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_ingress_controller:4.0.0:*:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_ingress_controller:4.0.1:*:*:*:*:*:*:* Versions 4.0.1 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_instance_manager:*:*:*:*:*:*:*:* Versions 2.17.0 – 2.22.0 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_open_source:*:*:*:*:*:*:*:* Versions 1.31.0 to before 1.31.2 Vulnerable ·F5
Remediation
- Fix · CNA NGINX Open Source (F5) Fixed in 1.31.2
Red Hat 1 advisory
- RHSA-2026:20351 Released 2026-05-23 · Red Hat rating ImportantRed Hat Hardened Images RPMs bug fix and enhancement update
- Red Hat Hardened Images nginx-1.30.2-1.hum1@aarch64, nginx-1.30.2-1.hum1@src, nginx-1.30.2-1.hum1@x86_64 +22
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Hardened Images | Fixed | RHSA-2026:20351 |
Not affected: 4 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
- Red Hat Lightspeed proxy 1
Timeline
- 2026-10-02 Threatist record created from CVE-2026-42530
- 2026-10-03 Alias added: GHSA-5mcp-3252-f5vr
- 2026-10-25 EPSS moved to the 90th–95th percentile
References
More F5 Nginx Gateway Fabric vulnerabilities
- TI-2026-31136 NGINX ngx_http_rewrite_module vulnerability CVSS 4.0CRITICAL 9.2
- TI-2026-30813 NGINX Map directive and Regex matching vulnerability CVSS 4.0CRITICAL 9.2
- TI-2026-08132 NGINX ngx_http_rewrite_module vulnerability CVSS 4.0CRITICAL 9.2
- TI-2026-30432 NGINX ngx_http_proxy_v2_module and ngx_http_grpc_module vulnerability CVSS 4.0CRITICAL 9.2
- TI-2026-42786 NGINX ngx_http_slice_module vulnerability CVSS 4.0HIGH 8.8
- TI-2026-36891 NGINX Gateway Fabric vulnerability CVSS 4.0HIGH 8.6
Sources
- CVE-2026-42530 · CVE Program
- CVE-2026-42530 · NVD
- FIRST EPSS
- GHSA-5mcp-3252-f5vr · GitHub Advisory Database · CC BY 4.0
- CVE-2026-42530 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences