NGINX ngx_http_charset_module vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · Low
- Fix status
- Partial Red Hat: 4 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and Red Hat.
Summary
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_charset_module module. When charset, source_charset, and charset_map and proxy_pass with disabled buffering ("off") directives are configured, unauthenticated attackers can send requests that with conditions beyond the attackers' control to cause a heap buffer over-read in the NGINX worker process, leading to limited disclosure of memory or a restart. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| F5 | NGINX Plus | R36 to before R36 P4; R32 to before R32 P6 | R37, R36 P4, R32 P6 | Patch available | CNA |
| F5 | NGINX Open Source | 0.3.50 to before 1.30.1 | 1.31.0, 1.30.1 | Patch available | CNA |
- NGINX Plus VendorF5 Affected R36 to before R36 P4; R32 to before R32 P6 Fixed in R37, R36 P4, R32 P6 Patch available CNA
- NGINX Open Source VendorF5 Affected 0.3.50 to before 1.30.1 Fixed in 1.31.0, 1.30.1 Patch available CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:f5:dos:*:*:*:*:*:nginx:*:* | 4.3.0 – 4.7.0 | Vulnerable | F5 |
| cpe:2.3:a:f5:dos:4.8.0:*:*:*:*:nginx:*:* | 4.8.0 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_gateway_fabric:*:*:*:*:*:*:*:* | 1.3.0 – 1.6.2; 2.0.0 – 2.6.0 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_ingress_controller:*:*:*:*:*:*:*:* | 3.5.0 – 3.7.2; 4.0.0 – 4.0.1; 5.0.0 – 5.4.2 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_instance_manager:*:*:*:*:*:*:*:* | 2.16.0 – 2.22.0 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_open_source:*:*:*:*:*:*:*:* | 0.3.50 – 0.9.7; 1.0.0 – 1.30.0 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_plus:*:*:*:*:*:*:*:* | r32 – r36 | Vulnerable | F5 |
| cpe:2.3:a:f5:waf:*:*:*:*:*:nginx:*:* | 4.9.0 – 4.16.0; 5.1.0 – 5.8.0; 5.9.0 – 5.12.1 | Vulnerable | F5 |
- cpe:2.3:a:f5:dos:*:*:*:*:*:nginx:*:* Versions 4.3.0 – 4.7.0 Vulnerable ·F5
- cpe:2.3:a:f5:dos:4.8.0:*:*:*:*:nginx:*:* Versions 4.8.0 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_gateway_fabric:*:*:*:*:*:*:*:* Versions 1.3.0 – 1.6.2; 2.0.0 – 2.6.0 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_ingress_controller:*:*:*:*:*:*:*:* Versions 3.5.0 – 3.7.2; 4.0.0 – 4.0.1; 5.0.0 – 5.4.2 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_instance_manager:*:*:*:*:*:*:*:* Versions 2.16.0 – 2.22.0 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_open_source:*:*:*:*:*:*:*:* Versions 0.3.50 – 0.9.7; 1.0.0 – 1.30.0 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_plus:*:*:*:*:*:*:*:* Versions r32 – r36 Vulnerable ·F5
- cpe:2.3:a:f5:waf:*:*:*:*:*:nginx:*:* Versions 4.9.0 – 4.16.0; 5.1.0 – 5.8.0; 5.9.0 – 5.12.1 Vulnerable ·F5
Remediation
- Fix · CNA NGINX Plus (F5) Fixed in R37, R36 P4, R32 P6
- Fix · CNA NGINX Open Source (F5) Fixed in 1.31.0, 1.30.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
F5 NGINX Open Source 1.30.1
6 records Highest priority Priority HIGH 1 HIGH, 5 LOW
Other records, highest priority first
- TI-2026-31136 NGINX ngx_http_rewrite_module vulnerabilityPriority HIGH 78
- TI-2026-31137 NGINX ngx_http_scgi_module and ngx_http_uwsgi_module vulnerabilityPriority LOW 38
- TI-2026-29212 NGINX ngx_quic_module vulnerabilityPriority LOW 37
- Release ·
F5 NGINX Plus R32 P6, R36 P4
5 records Highest priority Priority HIGH 1 HIGH, 4 LOW
Other records, highest priority first
- TI-2026-31136 NGINX ngx_http_rewrite_module vulnerabilityPriority HIGH 78
- TI-2026-31137 NGINX ngx_http_scgi_module and ngx_http_uwsgi_module vulnerabilityPriority LOW 38
- TI-2026-29212 NGINX ngx_quic_module vulnerabilityPriority LOW 37
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
| Red Hat Lightspeed proxy 1 | Affected | No fix yet: Fix deferred |
Not affected: 1 product
- Red Hat Hardened Images
Timeline
- 2026-10-02 Threatist record created from CVE-2026-42934
- 2026-10-03 Alias added: GHSA-6vmc-2wh4-77qp
References
More F5 Dos vulnerabilities
- TI-2026-31136 NGINX ngx_http_rewrite_module vulnerability CVSS 4.0CRITICAL 9.2
- TI-2026-08132 NGINX ngx_http_rewrite_module vulnerability CVSS 4.0CRITICAL 9.2
- TI-2026-30432 NGINX ngx_http_proxy_v2_module and ngx_http_grpc_module vulnerability CVSS 4.0CRITICAL 9.2
- TI-2026-31137 NGINX ngx_http_scgi_module and ngx_http_uwsgi_module vulnerability CVSS 4.0HIGH 8.3
- TI-2026-29212 NGINX ngx_quic_module vulnerability CVSS 4.0MEDIUM 6.9
- TI-2026-35579 NGINX ngx_http_charset_module vulnerability CVSS 4.0MEDIUM 6.3
Sources
- CVE-2026-42934 · CVE Program
- CVE-2026-42934 · NVD
- FIRST EPSS
- GHSA-6vmc-2wh4-77qp · GitHub Advisory Database · CC BY 4.0
- CVE-2026-42934 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences