NGINX ngx_http_charset_module vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · Low
- Fix status
- Partial Red Hat: 1 fixed, 3 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and Red Hat.
Summary
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_charset_module module. When content is served or proxied through a location block with both source_charset utf-8; and a charset directive (for example, charset koi8-r;) configured, remote, unauthenticated attackers can send requests (in conjunction with conditions beyond their control) to cause a heap buffer over-read in the NGINX worker process, leading to limited disclosure of memory or a restart. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| F5 | NGINX Open Source | 1.13.10 to before 1.31.2; 1.30.0 to before 1.30.3 | 1.31.2, 1.30.3 | Patch available | CNA |
| F5 | NGINX Plus | 37.0 to before 37.0.2.1; R36 to before R36 P6 | 37.0.2.1, R36 P6 | Patch available | CNA |
- NGINX Open Source VendorF5 Affected 1.13.10 to before 1.31.2; 1.30.0 to before 1.30.3 Fixed in 1.31.2, 1.30.3 Patch available CNA
- NGINX Plus VendorF5 Affected 37.0 to before 37.0.2.1; R36 to before R36 P6 Fixed in 37.0.2.1, R36 P6 Patch available CNA
CPE configurations NVD · 15
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:f5:dos:*:*:*:*:*:nginx:*:* | 4.3.0 – 4.7.0 | Vulnerable | F5 |
| cpe:2.3:a:f5:dos:4.9.0:*:*:*:*:nginx:*:* | 4.9.0 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_gateway_fabric:*:*:*:*:*:*:*:* | 1.3.0 – 1.6.2; 2.0.0 – 2.6.3 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_ingress_controller:*:*:*:*:continuous_releases:*:*:* | 3.5.0 – 3.7.2; 4.0.0 – 4.0.1; 5.0.0 – 5.5.0 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_instance_manager:*:*:*:*:*:*:*:* | 2.17.0 – 2.22.0 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_open_source:*:*:*:*:*:*:*:* | 1.0.0 – 1.30.2; 1.31.0 – 1.31.1 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_plus:*:*:*:*:long-term_support:*:*:* | 37.0.0.1 to before 37.0.2.1 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_plus:*:*:*:*:continuous_releases:*:*:* | r33 to before r36 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_plus:r36:-:*:*:continuous_releases:*:*:* | r36 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_plus:r36:p1:*:*:continuous_releases:*:*:* | r36 p1 | Vulnerable | F5 |
- cpe:2.3:a:f5:dos:*:*:*:*:*:nginx:*:* Versions 4.3.0 – 4.7.0 Vulnerable ·F5
- cpe:2.3:a:f5:dos:4.9.0:*:*:*:*:nginx:*:* Versions 4.9.0 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_gateway_fabric:*:*:*:*:*:*:*:* Versions 1.3.0 – 1.6.2; 2.0.0 – 2.6.3 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_ingress_controller:*:*:*:*:continuous_releases:*:*:* Versions 3.5.0 – 3.7.2; 4.0.0 – 4.0.1; 5.0.0 – 5.5.0 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_instance_manager:*:*:*:*:*:*:*:* Versions 2.17.0 – 2.22.0 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_open_source:*:*:*:*:*:*:*:* Versions 1.0.0 – 1.30.2; 1.31.0 – 1.31.1 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_plus:*:*:*:*:long-term_support:*:*:* Versions 37.0.0.1 to before 37.0.2.1 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_plus:*:*:*:*:continuous_releases:*:*:* Versions r33 to before r36 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_plus:r36:-:*:*:continuous_releases:*:*:* Versions r36 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_plus:r36:p1:*:*:continuous_releases:*:*:* Versions r36 p1 Vulnerable ·F5
Show 5 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:f5:nginx_plus:r36:p2:*:*:continuous_releases:*:*:* | r36 p2 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_plus:r36:p3:*:*:continuous_releases:*:*:* | r36 p3 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_plus:r36:p4:*:*:continuous_releases:*:*:* | r36 p4 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_plus:r36:p5:*:*:continuous_releases:*:*:* | r36 p5 | Vulnerable | F5 |
| cpe:2.3:a:f5:waf:*:*:*:*:*:nginx:*:* | 4.10.0 – 4.16.0; 5.2.0 – 5.8.0; 5.9.0 – 5.13.1 | Vulnerable | F5 |
- cpe:2.3:a:f5:nginx_plus:r36:p2:*:*:continuous_releases:*:*:* Versions r36 p2 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_plus:r36:p3:*:*:continuous_releases:*:*:* Versions r36 p3 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_plus:r36:p4:*:*:continuous_releases:*:*:* Versions r36 p4 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_plus:r36:p5:*:*:continuous_releases:*:*:* Versions r36 p5 Vulnerable ·F5
- cpe:2.3:a:f5:waf:*:*:*:*:*:nginx:*:* Versions 4.10.0 – 4.16.0; 5.2.0 – 5.8.0; 5.9.0 – 5.13.1 Vulnerable ·F5
Remediation
- Fix · CNA NGINX Open Source (F5) Fixed in 1.31.2, 1.30.3
- Fix · CNA NGINX Plus (F5) Fixed in 37.0.2.1, R36 P6
Red Hat 1 advisory
- RHSA-2026:27197 Released 2026-06-19 · Red Hat rating ImportantRed Hat Hardened Images RPMs bug fix and enhancement update
- Red Hat Hardened Images nginx-1.30.3-2.hum1@aarch64, nginx-1.30.3-2.hum1@src, nginx-1.30.3-2.hum1@x86_64 +22
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
F5 NGINX Open Source, NGINX Plus 1.30.3, 1.31.2 and 2 more versions
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2026-30432 NGINX ngx_http_proxy_v2_module and ngx_http_grpc_module vulnerabilityPriority MEDIUM 51
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
| Red Hat Hardened Images | Fixed | RHSA-2026:27197 |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-48142
- 2026-10-03 Alias added: GHSA-2388-jp8v-fg9w
- 2026-10-25 EPSS moved to the 50th–90th percentile
References
More F5 Dos vulnerabilities
- TI-2026-31136 NGINX ngx_http_rewrite_module vulnerability CVSS 4.0CRITICAL 9.2
- TI-2026-08132 NGINX ngx_http_rewrite_module vulnerability CVSS 4.0CRITICAL 9.2
- TI-2026-30432 NGINX ngx_http_proxy_v2_module and ngx_http_grpc_module vulnerability CVSS 4.0CRITICAL 9.2
- TI-2026-31137 NGINX ngx_http_scgi_module and ngx_http_uwsgi_module vulnerability CVSS 4.0HIGH 8.3
- TI-2026-29212 NGINX ngx_quic_module vulnerability CVSS 4.0MEDIUM 6.9
- TI-2026-31131 NGINX ngx_http_charset_module vulnerability CVSS 4.0MEDIUM 6.3
Sources
- CVE-2026-48142 · CVE Program
- CVE-2026-48142 · NVD
- FIRST EPSS
- GHSA-2388-jp8v-fg9w · GitHub Advisory Database · CC BY 4.0
- CVE-2026-48142 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences