Parse Server: MFA SMS one-time password accepted twice under concurrent login
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 8.6.76 and 9.9.0-alpha.2, a race condition in the MFA SMS one-time password (OTP) login path allows two concurrent /login requests carrying the same OTP to both succeed and both receive valid session tokens, breaking the single-use property of the OTP. The vulnerability requires the attacker to already possess the victim's password and intercept the active SMS OTP (e.g. via SIM swap, network mirror, or phishing relay) and to race the legitimate login request, so the practical attack surface is narrow. This vulnerability is fixed in 8.6.76 and 9.9.0-alpha.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| parse-community | parse-server | 9.0.0 to before 9.9.0-alpha.2; before 8.6.76 | 9.9.0-alpha.2, 8.6.76 | Patch available | CNA |
| — | parse-server (npm) | 9.0.0 to before 9.9.0-alpha.2 | 9.9.0-alpha.2 | Patch available | GHSA-jpq4-7fmq-q5fj |
| — | parse-server (npm) | before 8.6.76 | 8.6.76 | Patch available | GHSA-jpq4-7fmq-q5fj |
- parse-server Vendorparse-community Affected 9.0.0 to before 9.9.0-alpha.2; before 8.6.76 Fixed in 9.9.0-alpha.2, 8.6.76 Patch available CNA
- parse-server (npm) Vendor— Affected 9.0.0 to before 9.9.0-alpha.2 Fixed in 9.9.0-alpha.2 Patch available GHSA-jpq4-7fmq-q5fj
- parse-server (npm) Vendor— Affected before 8.6.76 Fixed in 8.6.76 Patch available GHSA-jpq4-7fmq-q5fj
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* | before 8.6.76; 9.0.0 to before 9.9.0 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.9.0:alpha1:*:*:*:node.js:*:* | 9.9.0 alpha1 | Vulnerable | parse-community |
- cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* Versions before 8.6.76; 9.0.0 to before 9.9.0 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.9.0:alpha1:*:*:*:node.js:*:* Versions 9.9.0 alpha1 Vulnerable ·parse-community
Remediation
- Fix · CNA parse-server (parse-community) Fixed in 9.9.0-alpha.2, 8.6.76
- Fix · GHSA-jpq4-7fmq-q5fj parse-server (npm) Fixed in 9.9.0-alpha.2 Advisory →
- Fix · GHSA-jpq4-7fmq-q5fj parse-server (npm) Fixed in 8.6.76 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-43930
- 2026-10-03 Alias added: GHSA-jpq4-7fmq-q5fj
References
Patch 2
Advisory 2
More parse-community Parse-server vulnerabilities
- TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
- TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
- TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
- TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
- TI-2023-18316 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution CVSS 3.1CRITICAL 9.8
- TI-2026-23790 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter CVSS 4.0CRITICAL 9.9
Sources
- CVE-2026-43930 · CVE Program
- CVE-2026-43930 · NVD
- FIRST EPSS
- GHSA-jpq4-7fmq-q5fj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences