Cross-site scripting in getgrav grav-plugin-admin
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
grav-plugin-admin is the admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.10.49.5, the application fails to properly validate and sanitize user input in the data[header][title] parameter. As a result, attackers can craft a malicious URL with an XSS payload. When this URL is accessed, the injected script is reflected back in the HTTP response and executed within the context of the victim's browser session. This vulnerability is fixed in 1.10.49.5.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| getgrav | grav-plugin-admin | before 1.10.49.5 | 1.10.49.5 | Patch available | CNA |
| — | getgrav/grav (Packagist) | before 1.7.49.5 | 1.7.49.5 | Patch available | GHSA-fmg2-f5r9-24qc |
- grav-plugin-admin Vendorgetgrav Affected before 1.10.49.5 Fixed in 1.10.49.5 Patch available CNA
- getgrav/grav (Packagist) Vendor— Affected before 1.7.49.5 Fixed in 1.7.49.5 Patch available GHSA-fmg2-f5r9-24qc
Remediation
- Fix · CNA grav-plugin-admin (getgrav) Fixed in 1.10.49.5
- Fix · GHSA-fmg2-f5r9-24qc getgrav/grav (Packagist) Fixed in 1.7.49.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-44737
- 2026-10-03 Alias added: GHSA-fmg2-f5r9-24qc
References
More getgrav vulnerabilities
- TI-2026-30893 Grav: Privilege Escalation via Missing Server-Side Validation of groups/access CVSS 3.1CRITICAL 9.4
- TI-2025-28971 Cross Site Scripting vulnerability in grav v.1.7.48 and before allows an attacker to… CVSS 3.1CRITICAL 9.8
- TI-2021-04523 Unauthenticated Arbitrary YAML Write/Update leads to Code Execution CVSS 3.1CRITICAL 9.8
- TI-2026-50940 Grav CMS before 2.0.16 Origin Validation Bypass via Referer CVSS 4.0CRITICAL 9.3
- TI-2026-46446 Grav before 2.0.7 Remote Code Execution via Blueprint dynamicData CVSS 4.0CRITICAL 9.3
- TI-2021-22428 GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2) CVSS 4.0CRITICAL 9.3
Sources
- CVE-2026-44737 · CVE Program
- CVE-2026-44737 · NVD
- FIRST EPSS
- GHSA-fmg2-f5r9-24qc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences