Read the docs
TI-2021-04523 Aliases CVE-2021-21425

Unauthenticated Arbitrary YAML Write/Update leads to Code Execution

Priority HIGH 82CWE-284Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-284.

Summary

Grav Admin Plugin is an HTML user interface that provides a way to configure Grav and create and modify pages. In versions 1.10.7 and earlier, an unauthenticated user can execute some methods of administrator controller without needing any credentials. Particular method execution will result in arbitrary YAML file creation or content change of existing YAML files on the system. Successfully exploitation of that vulnerability results in configuration changes, such as general site information change, custom scheduler job definition, etc. Due to the nature of the vulnerability, an adversary can change some part of the webpage, or hijack an administrator account, or execute operating system command under the context of the web-server user. This vulnerability is fixed in version 1.10.8. Blocking access to the `/admin` path from untrusted sources can be applied as a workaround.

Why it matters now

EPSS 0.806 99th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
getgravgrav-plugin-adminup to 1.10.7—No fix listedCNA
  • grav-plugin-admin Vendorgetgrav Affected up to 1.10.7 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:getgrav:grav-plugin-admin:*:*:*:*:*:*:*:*before 1.10.8Vulnerablegetgrav
  • cpe:2.3:a:getgrav:grav-plugin-admin:*:*:*:*:*:*:*:* Versions before 1.10.8 Vulnerable ·getgrav

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-21425

References

  • TI-2025-40781 Grav Admin Plugin vulnerable to User Enumeration & Email Disclosure CVSS 3.1MEDIUM 6.5
  • TI-2025-40782 Cross-site scripting in getgrav grav CVSS 4.0MEDIUM 6.8
  • TI-2025-40786 Cross-site scripting in getgrav grav CVSS 4.0MEDIUM 6.2
  • TI-2025-40785 Grav vulnerable to Cross-Site Scripting (XSS) Stored endpoint `/admin/pages/[page]` in Multiples parameters CVSS 4.0MEDIUM 6.2
  • TI-2025-40784 Cross-site scripting in getgrav grav CVSS 4.0MEDIUM 6.2
  • TI-2025-40783 Cross-site scripting in getgrav grav CVSS 4.0MEDIUM 6.2
See all 8 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences