FrankenPHP: Unsafe Unicode Handling in CGI Path Splitting Allows Execution of Non-PHP Files
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
FrankenPHP is a modern application server for PHP. From version 1.11.2 to before version 1.12.3, the splitPos() function in cgi.go misuses golang.org/x/text/search with search.IgnoreCase when the request path contains a non-ASCII byte. Two distinct flaws in that fallback let an attacker mislead FrankenPHP into treating a non-.php file as a .php script. In any deployment where the attacker can place content into a file served by FrankenPHP (uploads, file storage, etc.), this can be escalated to remote code execution by crafting a URL whose path triggers either flaw. This issue has been patched in version 1.12.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PHP | frankenphp | 1.11.2 to before 1.12.3 | 1.12.3 | Patch available | CNA |
| — | github.com/dunglas/frankenphp (Go) | 1.11.2 to before 1.12.3 | 1.12.3 | Patch available | GHSA-3g8v-8r37-cgjm |
- frankenphp VendorPHP Affected 1.11.2 to before 1.12.3 Fixed in 1.12.3 Patch available CNA
- github.com/dunglas/frankenphp (Go) Vendor— Affected 1.11.2 to before 1.12.3 Fixed in 1.12.3 Patch available GHSA-3g8v-8r37-cgjm
Remediation
- Fix · CNA frankenphp (php) Fixed in 1.12.3
- Fix · GHSA-3g8v-8r37-cgjm github.com/dunglas/frankenphp (Go) Fixed in 1.12.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-45062
- 2026-10-03 Alias added: GHSA-3g8v-8r37-cgjm
- 2026-10-25 EPSS moved to the below the 50th percentile
- 2026-10-26 EPSS moved to the 50th–90th percentile
References
More PHP vulnerabilities
- TI-2024-04260 Argument Injection in PHP-CGI KEVCVSS 3.1CRITICAL 9.8
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2016-08118 The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-01607 sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-78794 PHP remote code execution via stale global state KEVCVSS 4.0CRITICAL 9.2
- TI-2026-78793 Out-of-memory handling flaw in PHP allows remote code execution KEVCVSS 4.0CRITICAL 9.2
Sources
- CVE-2026-45062 · CVE Program
- CVE-2026-45062 · NVD
- FIRST EPSS
- GHSA-3g8v-8r37-cgjm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences