Symfony: HEAD Request Bypasses methods: ['GET'] Filter in #[IsGranted] / #[IsSignatureValid] / #[IsCsrfTokenValid]
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 7.4.12 and 8.0.12, method-scoped #[IsGranted], #[IsSignatureValid], and #[IsCsrfTokenValid] attributes can be configured for GET only, but Symfony routes HEAD requests to the GET handler while the attribute check is skipped, allowing protected controllers to execute and leak headers or perform side effects. This issue is fixed in versions 7.4.12 and 8.0.12.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| symfony | symfony | 7.4.0-BETA1 to before 7.4.12; 8.0.0-BETA1 to before 8.0.12 | 7.4.12, 8.0.12 | Patch available | CNA |
| symfony | http-kernel | 7.4.0-BETA1 to before 7.4.12; 8.0.0-BETA1 to before 8.0.12 | 7.4.12, 8.0.12 | Patch available | CNA |
| symfony | security-http | 7.4.0-BETA1 to before 7.4.12; 8.0.0-BETA1 to before 8.0.12 | 7.4.12, 8.0.12 | Patch available | CNA |
| — | symfony/http-kernel (Packagist) | 7.4.0 to before 7.4.12 | 7.4.12 | Patch available | GHSA-6439-2f28-8p8q |
| — | symfony/http-kernel (Packagist) | 8.0.0 to before 8.0.12 | 8.0.12 | Patch available | GHSA-6439-2f28-8p8q |
| — | symfony/security-http (Packagist) | 7.4.0 to before 7.4.12 | 7.4.12 | Patch available | GHSA-6439-2f28-8p8q |
| — | symfony/security-http (Packagist) | 8.0.0 to before 8.0.12 | 8.0.12 | Patch available | GHSA-6439-2f28-8p8q |
| — | symfony/symfony (Packagist) | 7.4.0 to before 7.4.12 | 7.4.12 | Patch available | GHSA-6439-2f28-8p8q |
| — | symfony/symfony (Packagist) | 8.0.0 to before 8.0.12 | 8.0.12 | Patch available | GHSA-6439-2f28-8p8q |
- symfony Vendorsymfony Affected 7.4.0-BETA1 to before 7.4.12; 8.0.0-BETA1 to before 8.0.12 Fixed in 7.4.12, 8.0.12 Patch available CNA
- http-kernel Vendorsymfony Affected 7.4.0-BETA1 to before 7.4.12; 8.0.0-BETA1 to before 8.0.12 Fixed in 7.4.12, 8.0.12 Patch available CNA
- security-http Vendorsymfony Affected 7.4.0-BETA1 to before 7.4.12; 8.0.0-BETA1 to before 8.0.12 Fixed in 7.4.12, 8.0.12 Patch available CNA
- symfony/http-kernel (Packagist) Vendor— Affected 7.4.0 to before 7.4.12 Fixed in 7.4.12 Patch available GHSA-6439-2f28-8p8q
- symfony/http-kernel (Packagist) Vendor— Affected 8.0.0 to before 8.0.12 Fixed in 8.0.12 Patch available GHSA-6439-2f28-8p8q
- symfony/security-http (Packagist) Vendor— Affected 7.4.0 to before 7.4.12 Fixed in 7.4.12 Patch available GHSA-6439-2f28-8p8q
- symfony/security-http (Packagist) Vendor— Affected 8.0.0 to before 8.0.12 Fixed in 8.0.12 Patch available GHSA-6439-2f28-8p8q
- symfony/symfony (Packagist) Vendor— Affected 7.4.0 to before 7.4.12 Fixed in 7.4.12 Patch available GHSA-6439-2f28-8p8q
- symfony/symfony (Packagist) Vendor— Affected 8.0.0 to before 8.0.12 Fixed in 8.0.12 Patch available GHSA-6439-2f28-8p8q
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* | 7.4.0 to before 7.4.12; 8.0.0 to before 8.0.12 | Vulnerable | sensiolabs |
- cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* Versions 7.4.0 to before 7.4.12; 8.0.0 to before 8.0.12 Vulnerable ·sensiolabs
Remediation
- Fix · CNA symfony (symfony) Fixed in 7.4.12, 8.0.12
- Fix · CNA http-kernel (symfony) Fixed in 7.4.12, 8.0.12
- Fix · CNA security-http (symfony) Fixed in 7.4.12, 8.0.12
- Fix · GHSA-6439-2f28-8p8q symfony/http-kernel (Packagist) Fixed in 7.4.12 Advisory →
- Fix · GHSA-6439-2f28-8p8q symfony/http-kernel (Packagist) Fixed in 8.0.12 Advisory →
- Fix · GHSA-6439-2f28-8p8q symfony/security-http (Packagist) Fixed in 7.4.12 Advisory →
- Fix · GHSA-6439-2f28-8p8q symfony/security-http (Packagist) Fixed in 8.0.12 Advisory →
- Fix · GHSA-6439-2f28-8p8q symfony/symfony (Packagist) Fixed in 7.4.12 Advisory →
- Fix · GHSA-6439-2f28-8p8q symfony/symfony (Packagist) Fixed in 8.0.12 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-45075
- 2026-10-03 Alias added: GHSA-6439-2f28-8p8q
References
Other 8
- https://github.com/symfony/symfony/releases/tag/v7.4.12
- https://github.com/symfony/symfony/releases/tag/v8.0.12
- https://github.com/symfony/symfony/commit/fa8d5c67aa4b22c9656e3fd7d5c3aa59865bf838
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/http-kernel/CVE-2026-45075.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/security-http/CVE-2026-45075.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2026-45075.yaml
- https://github.com/symfony/symfony
- https://symfony.com/cve-2026-45075
More symfony vulnerabilities
- TI-2024-33775 Ability to change environment from query in symfony/runtime CVSS 3.1HIGH 7.3
- TI-2026-34283 Twig: The `spaceless` filter implicitly marks its output as safe CVSS 4.0MEDIUM 5.1
- TI-2022-07667 Code injection in Twig CVSS 3.1CRITICAL 9.8
- TI-2018-10028 Twig before 2.4.4 allows Server-Side Template Injection (SSTI) via the search search_key… CVSS 3.0CRITICAL 9.8
- TI-2026-35851 Incorrect authorization in symfony CVSS 4.0HIGH 8.7
- TI-2026-35264 Improper input validation in symfony CVSS 4.0HIGH 8.3
Sources
- CVE-2026-45075 · CVE Program
- CVE-2026-45075 · NVD
- FIRST EPSS
- GHSA-6439-2f28-8p8q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences