Read the docs
TI-2026-32966 Aliases CVE-2026-45133GHSA-c2p3-7m5p-cv8x

Symfony: [Yaml] Harden the parser when handling untrusted input

Priority LOW 37CWE-1333Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-1333.

Summary

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, when the parser is exposed to attacker-controlled input, deeply nested mappings or sequences cause both the block-level (Parser::parseBlock()) and inline (Inline::parseSequence() / Inline::parseMapping()) parsers to recurse without a depth limit. A crafted document exhausts the PHP stack and crashes the worker. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0063 50th percentileScored 2026-11-07
Fix Fixed symfony (symfony): 5.4.52, 6.4.40, 7.4.12 +1symfony/yaml (Packagist): 5.4.52, 6.4.40, 7.4.12 +1+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
symfonysymfonybefore 5.4.52; 6.0.0-BETA1 to before 6.4.40; 7.0.0-BETA1 to before 7.4.12; 8.0.0-BETA1 to before 8.0.125.4.52, 6.4.40, 7.4.12, 8.0.12Patch availableCNA
—symfony/yaml (Packagist)before 5.4.525.4.52Patch availableGHSA-c2p3-7m5p-cv8x
—symfony/symfony (Packagist)before 5.4.525.4.52Patch availableGHSA-c2p3-7m5p-cv8x
—symfony/symfony (Packagist)6.0.0 to before 6.4.406.4.40Patch availableGHSA-c2p3-7m5p-cv8x
—symfony/symfony (Packagist)7.0.0 to before 7.4.127.4.12Patch availableGHSA-c2p3-7m5p-cv8x
—symfony/symfony (Packagist)8.0.0 to before 8.0.128.0.12Patch availableGHSA-c2p3-7m5p-cv8x
—symfony/yaml (Packagist)6.0.0 to before 6.4.406.4.40Patch availableGHSA-c2p3-7m5p-cv8x
—symfony/yaml (Packagist)7.0.0 to before 7.4.127.4.12Patch availableGHSA-c2p3-7m5p-cv8x
—symfony/yaml (Packagist)8.0.0 to before 8.0.128.0.12Patch availableGHSA-c2p3-7m5p-cv8x
  • symfony Vendorsymfony Affected before 5.4.52; 6.0.0-BETA1 to before 6.4.40; 7.0.0-BETA1 to before 7.4.12; 8.0.0-BETA1 to before 8.0.12 Fixed in 5.4.52, 6.4.40, 7.4.12, 8.0.12 Patch available CNA
  • symfony/yaml (Packagist) Vendor— Affected before 5.4.52 Fixed in 5.4.52 Patch available GHSA-c2p3-7m5p-cv8x
  • symfony/symfony (Packagist) Vendor— Affected before 5.4.52 Fixed in 5.4.52 Patch available GHSA-c2p3-7m5p-cv8x
  • symfony/symfony (Packagist) Vendor— Affected 6.0.0 to before 6.4.40 Fixed in 6.4.40 Patch available GHSA-c2p3-7m5p-cv8x
  • symfony/symfony (Packagist) Vendor— Affected 7.0.0 to before 7.4.12 Fixed in 7.4.12 Patch available GHSA-c2p3-7m5p-cv8x
  • symfony/symfony (Packagist) Vendor— Affected 8.0.0 to before 8.0.12 Fixed in 8.0.12 Patch available GHSA-c2p3-7m5p-cv8x
  • symfony/yaml (Packagist) Vendor— Affected 6.0.0 to before 6.4.40 Fixed in 6.4.40 Patch available GHSA-c2p3-7m5p-cv8x
  • symfony/yaml (Packagist) Vendor— Affected 7.0.0 to before 7.4.12 Fixed in 7.4.12 Patch available GHSA-c2p3-7m5p-cv8x
  • symfony/yaml (Packagist) Vendor— Affected 8.0.0 to before 8.0.12 Fixed in 8.0.12 Patch available GHSA-c2p3-7m5p-cv8x

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:*before 5.4.52; 6.0.0 to before 6.4.40; 7.0.0 to before 7.4.12; 8.0.0 to before 8.0.12Vulnerablesensiolabs
  • cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* Versions before 5.4.52; 6.0.0 to before 6.4.40; 7.0.0 to before 7.4.12; 8.0.0 to before 8.0.12 Vulnerable ·sensiolabs

Remediation

  • Fix · CNA symfony (symfony) Fixed in 5.4.52, 6.4.40, 7.4.12, 8.0.12
  • Fix · GHSA-c2p3-7m5p-cv8x symfony/yaml (Packagist) Fixed in 5.4.52 Advisory →
  • Fix · GHSA-c2p3-7m5p-cv8x symfony/symfony (Packagist) Fixed in 5.4.52 Advisory →
  • Fix · GHSA-c2p3-7m5p-cv8x symfony/symfony (Packagist) Fixed in 6.4.40 Advisory →
  • Fix · GHSA-c2p3-7m5p-cv8x symfony/symfony (Packagist) Fixed in 7.4.12 Advisory →
  • Fix · GHSA-c2p3-7m5p-cv8x symfony/symfony (Packagist) Fixed in 8.0.12 Advisory →
  • Fix · GHSA-c2p3-7m5p-cv8x symfony/yaml (Packagist) Fixed in 6.4.40 Advisory →
  • Fix · GHSA-c2p3-7m5p-cv8x symfony/yaml (Packagist) Fixed in 7.4.12 Advisory →
  • Fix · GHSA-c2p3-7m5p-cv8x symfony/yaml (Packagist) Fixed in 8.0.12 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-45133
  2. 2026-10-03 Alias added: GHSA-c2p3-7m5p-cv8x
  3. 2026-10-28 EPSS moved to the 50th–90th percentile

References

  • TI-2024-33775 Ability to change environment from query in symfony/runtime CVSS 3.1HIGH 7.3
  • TI-2026-34283 Twig: The `spaceless` filter implicitly marks its output as safe CVSS 4.0MEDIUM 5.1
  • TI-2022-07667 Code injection in Twig CVSS 3.1CRITICAL 9.8
  • TI-2018-10028 Twig before 2.4.4 allows Server-Side Template Injection (SSTI) via the search search_key… CVSS 3.0CRITICAL 9.8
  • TI-2026-35851 Incorrect authorization in symfony CVSS 4.0HIGH 8.7
  • TI-2026-35264 Improper input validation in symfony CVSS 4.0HIGH 8.3
See all 94 →

Sources