LibreNMS: Reflected XSS in the Proxmox app view via unsanitized instance/vmid parameters
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
LibreNMS is a network monitoring system. In versions up to and including 26.4.0, the Proxmox application view is vulnerable to reflected cross-site scripting through the user-supplied instance and vmid GET parameters, which are reflected into the page title without adequate encoding. The parameters are placed into the page title with only strip_tags applied, and the title is then written into an inline document.title assignment through string interpolation, so a single quote terminates the JavaScript string and the remaining input runs as script. An attacker who lures an authenticated user into following a crafted link can execute script in that user's session, enabling actions such as theft of session data. This issue is fixed in version 26.5.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| librenms | librenms | before 26.5.0 | 26.5.0 | Patch available | CNA |
| — | librenms/librenms (Packagist) | before 26.5.0 | 26.5.0 | Patch available | GHSA-jmqm-f8q4-v7wx |
- librenms Vendorlibrenms Affected before 26.5.0 Fixed in 26.5.0 Patch available CNA
- librenms/librenms (Packagist) Vendor— Affected before 26.5.0 Fixed in 26.5.0 Patch available GHSA-jmqm-f8q4-v7wx
Remediation
- Fix · CNA librenms (librenms) Fixed in 26.5.0
- Fix · GHSA-jmqm-f8q4-v7wx librenms/librenms (Packagist) Fixed in 26.5.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-45694
- 2026-10-03 Alias added: GHSA-jmqm-f8q4-v7wx
References
More librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-71173 LDAP filter injection in LibreNMS allows authentication bypass CVSS 4.0CRITICAL 9.2
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2026-57885 LibreNMS before 26.7.0 Stored XSS via Oxidized API CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2026-57886 LibreNMS before 26.5.0 Remote Code Execution via AboutController CVSS 4.0HIGH 8.7
Sources
- CVE-2026-45694 · CVE Program
- CVE-2026-45694 · NVD
- FIRST EPSS
- GHSA-jmqm-f8q4-v7wx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences