Read the docs

librenms

Records124All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical11CVSS 9.0–10.0
CVSS high32CVSS 7.0–8.9

Exploited now

librenms records in CISA KEV

No librenms vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

124 records

Priority HIGH 80

LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the $_POST['community'] parameter to html/pages/addhost.inc.php during creation of a new device, and then making a /ajax_output.php?id=captu…

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.71487 Published 2019-04-24 No fix listed CWE-78
Priority HIGH 75

LibreNMS before 26.9.0 contains an LDAP filter injection in ldap-authorization and ad-authorization modes because usernames are inserted unescaped into LDAP search filters and authentication only checks user existence.

CVSS 4.0CRITICAL 9.2 Network No auth No interaction EPSS 0.00596 Published 2026-10-12 Fixed in 26.9.0 CWE-90
Priority HIGH 75

LibreNMS before 26.8.0 contains an authentication bypass vulnerability in the REST API that allows unauthenticated attackers to access protected endpoints by sending numeric values instead of string tokens.

CVSS 4.0CRITICAL 9.2 Network No auth No interaction EPSS 0.04358 Published 2026-09-07 Fixed in 26.8.0 CWE-287
Priority HIGH 75

LibreNMS through 26.4.0 renders JSON fields (name, ip, model, author, commit message) returned by the admin-configurable Oxidized integration URL (oxidized.url) into the device showconfig page without applying htmlspecia…

CVSS 4.0CRITICAL 9.2 Network High privileges User interaction EPSS 0.00382 Published 2026-09-01 Fixed in 26.7.0 CWE-79
Priority HIGH 75

Insufficient Session Expiration in GitHub repository librenms/librenms prior to 22.10.0.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00662 Published 2022-11-20 Fixed in 22.10.0 CWE-613
Priority HIGH 73

LibreNMS versions before 26.5.0 contain a remote code execution vulnerability in the AboutController where the snmpget configuration parameter is passed to shell_exec() without proper validation.

CVSS 4.0HIGH 8.7 Network Low privileges No interaction EPSS 0.00863 Published 2026-09-01 Fixed in 26.5.0 CWE-77
Priority HIGH 73

Deserialization of Untrusted Data in GitHub repository librenms/librenms prior to 22.10.0.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00951 Published 2022-11-20 Fixed in 22.10.0 CWE-502
Priority HIGH 72

LibreNMS versions >= 23.10.0 and < 26.2.0 (fixed in 26.4.0) contain an authenticated OS command injection vulnerability in libvirt discovery.

CVSS 4.0HIGH 8.6 Network High privileges No interaction EPSS 0.01526 Published 2026-09-01 Fixed in 26.4.0 CWE-78
TI-2026-55455 CVE-2026-80214 · GHSA-gq95-24rp-w6h2

LibreNMS Virtualisation Discovery Module RCE

Priority HIGH 72

LibreNMS’s Virtualization Discovery module is vulnerable to command line injection.

CVSS 4.0HIGH 8.6 Network High privileges No interaction EPSS 0.00539 Published 2026-08-26 Fixed in 26.4.1 CWE-78
TI-2026-05445 CVE-2026-6204 · GHSA-pr3g-phhr-h8fh

OS command injection in librenms

Priority HIGH 72

LibreNMS versions before 26.3.0 are affected by an authenticated remote code execution vulnerability by abusing the Binary Locations config and the Netcommand feature.

CVSS 4.0HIGH 8.5 Network High privileges No interaction EPSS 0.07533 Published 2026-04-13 Fixed in 26.3.0 CWE-78
Priority HIGH 72

LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command injection involving AboutController.php's index(), SettingsController.php's update(), and PollDevice.php's initRrdDirectory().

CVSS 3.1CRITICAL 9.1 Network Low privileges No interaction EPSS 0.07176 Published 2026-05-08 Fixed in 24.10.0 CWE-78
Priority HIGH 72

LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring which includes support for a wide range of network hardware and operating systems.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00599 Published 2023-11-17 Fixed in 23.11.0 CWE-307
Priority HIGH 68

Cross-site Scripting (XSS) - Stored in GitHub repository librenms/librenms prior to 22.10.0.

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.93712 Published 2022-11-20 Fixed in 22.10.0 CWE-79
Priority HIGH 68

Cross-site Scripting (XSS) - Stored in GitHub repository librenms/librenms prior to 22.10.0.

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.94216 Published 2022-11-20 Fixed in 22.10.0 CWE-79
Priority HIGH 66

Cross-site Scripting (XSS) - Generic in GitHub repository librenms/librenms prior to 22.10.0.

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.93343 Published 2022-11-20 Fixed in 22.10.0 CWE-79
Priority MEDIUM 64

LibreNMS before 26.9.0 contains an SQL injection vulnerability that allows unprivileged users to inject SQL by supplying an array-valued notification_id parameter to notifications.inc.php.

CVSS 4.0HIGH 7.1 Network Low privileges No interaction EPSS 0.00294 Published 2026-10-12 Fixed in 26.9.0 CWE-89
Priority MEDIUM 64

LibreNMS before 26.3.1 contains a stored cross-site scripting vulnerability in legacy PHP templates that output SNMP-sourced and syslog-sourced data without escaping.

CVSS 4.0HIGH 7.1 Network No auth User interaction EPSS 0.00331 Published 2026-09-01 Fixed in 26.3.1 CWE-79
Load more
Open these records in search →