Malicious code in guardrails-ai 0.10.1 (supply chain compromise)
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-506.
Summary
Guardrails AI is a Python framework that helps build AI applications. On May 11, 2026 at approximately 6:00 PM Pacific, an attacker published a malicious version of `guardrails-ai` (0.10.1) to PyPI. Aany user who installed `guardrails-ai==0.10.1` from PyPI on May 11, 2026 may be affected. Security researchers identified the malicious package within approximately 2 hours of publication, and PyPI quarantined the repository. Based on our telemetry, Guardrails AI maintainers have observed no requests to Guardrails AI infrastructure originating from the malicious 0.10.1 version, and a review of system and access logs has produced no evidence of user data exfiltration through their systems. Users should upgrade to version 0.10.2 or downgrade to version 0.10.0, both of which are unaffected. Those who installed version 0.10.1 should rotate any credentials accessible from their machine (GitHub PATs, cloud provider keys, package registry tokens, API keys) and audit their GitHub account for unauthorized workflows or repositories.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Guardrails AI | guardrails | = 0.10.1 | — | No fix listed | CNA |
| — | guardrails-ai (PyPI) | — | — | No fix listed | GHSA-xmpw-2vmm-p4p6 |
- guardrails VendorGuardrails AI Affected = 0.10.1 Fixed in — No fix listed CNA
- guardrails-ai (PyPI) Vendor— Affected — Fixed in — No fix listed GHSA-xmpw-2vmm-p4p6
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:guardrailsai:guardrails_ai:0.10.1:*:*:*:*:python:*:* | 0.10.1 | Vulnerable | Guardrails AI |
- cpe:2.3:a:guardrailsai:guardrails_ai:0.10.1:*:*:*:*:python:*:* Versions 0.10.1 Vulnerable ·Guardrails AI
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-45758
- 2026-10-03 Alias added: GHSA-xmpw-2vmm-p4p6
References
Advisory 3
More Guardrails Ai vulnerabilities
- TI-2026-33119 Malware in 42 @tanstack/* packages exfiltrates cloud credentials, GitHub tokens, and SSH keys KEVCVSS 3.1CRITICAL 9.6
Sources
- CVE-2026-45758 · CVE Program
- CVE-2026-45758 · NVD
- FIRST EPSS
- GHSA-xmpw-2vmm-p4p6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences