Vendors / Guardrails AI Records 3 All Threatist records
Exploited (KEV) 1 In CISA KEV
CVSS critical 2 CVSS 9.0–10.0
CVSS high 1 CVSS 7.0–8.9
Exploited now Guardrails AI records in CISA KEV
Components Products in the NVD configurations · select one to filter the records Priority CRITICAL 100KEV
On 2026-05-11, between approximately 19:20 and 19:26 UTC, 84 malicious versions across 42 @tanstack/* packages were published to the npm registry.
CVSS 3.1 CRITICAL 9.6· Network · No auth · User interaction · EPSS 0.03278 · Published 2026-05-12 · Fixed in 1.166.16, 1.161.13 +26 CWE-506
Priority HIGH 69
An arbitrary code execution vulnerability exists in versions 0.2.9 up to 0.5.10 of the Guardrails AI Guardrails framework because of the way it validates XML files.
CVSS 3.1 HIGH 7.8· Local · No auth · User interaction · EPSS 0.00378 · Published 2024-09-18 · Fixed in 0.5.10 CWE-95
Priority MEDIUM 43
Guardrails AI is a Python framework that helps build AI applications.
CVSS 3.1 CRITICAL 9.6· Network · No auth · User interaction · EPSS 0.00276 · Published 2026-06-05 · No fix listed CWE-506
Open these records in search → All records by CVSS severity
Critical2 High1 Medium0 Low0 No CVSS0