Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Incomplete authorization during destination removal
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Partial Red Hat: 10 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-285.
Summary
Incomplete authorization by Apache ActiveMQ server before versions v6.2.6 and v5.19.7 allows authenticated connections to remove existing destinations with proper permissions. This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version v6.2.6 or v5.19.7, which fixes the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache ActiveMQ Broker | before 5.19.7; 6.0.0 to before 6.2.6 | 5.19.7, 6.2.6 | Patch available | CNA |
| Apache | Apache ActiveMQ All | before 5.19.7; 6.0.0 to before 6.2.6 | 5.19.7, 6.2.6 | Patch available | CNA |
| Apache | Apache ActiveMQ | before 5.19.7; 6.0.0 to before 6.2.6 | 5.19.7, 6.2.6 | Patch available | CNA |
| — | org.apache.activemq:apache-activemq (Maven) | before 5.19.7 | 5.19.7 | Patch available | GHSA-cpw7-g3p5-qrfq |
| — | org.apache.activemq:apache-activemq (Maven) | 6.0.0 to before 6.2.6 | 6.2.6 | Patch available | GHSA-cpw7-g3p5-qrfq |
- Apache ActiveMQ Broker VendorApache Affected before 5.19.7; 6.0.0 to before 6.2.6 Fixed in 5.19.7, 6.2.6 Patch available CNA
- Apache ActiveMQ All VendorApache Affected before 5.19.7; 6.0.0 to before 6.2.6 Fixed in 5.19.7, 6.2.6 Patch available CNA
- Apache ActiveMQ VendorApache Affected before 5.19.7; 6.0.0 to before 6.2.6 Fixed in 5.19.7, 6.2.6 Patch available CNA
- org.apache.activemq:apache-activemq (Maven) Vendor— Affected before 5.19.7 Fixed in 5.19.7 Patch available GHSA-cpw7-g3p5-qrfq
- org.apache.activemq:apache-activemq (Maven) Vendor— Affected 6.0.0 to before 6.2.6 Fixed in 6.2.6 Patch available GHSA-cpw7-g3p5-qrfq
Remediation
- Fix · CNA Apache ActiveMQ Broker (Apache Software Foundation) Fixed in 5.19.7, 6.2.6
- Fix · CNA Apache ActiveMQ All (Apache Software Foundation) Fixed in 5.19.7, 6.2.6
- Fix · CNA Apache ActiveMQ (Apache Software Foundation) Fixed in 5.19.7, 6.2.6
- Fix · GHSA-cpw7-g3p5-qrfq org.apache.activemq:apache-activemq (Maven) Fixed in 5.19.7 Advisory →
- Fix · GHSA-cpw7-g3p5-qrfq org.apache.activemq:apache-activemq (Maven) Fixed in 6.2.6 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apache ActiveMQ 5.19.7, 6.2.6
6 records Highest priority Priority MEDIUM 2 MEDIUM, 4 LOW
Other records, highest priority first
- TI-2026-33275 Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Jolokia `addNetworkConnector` Discovery Wrapper BypassPriority MEDIUM 41
- TI-2026-36361 Apache ActiveMQ: Authenticated low-privilege Web users retain Jolokia broker-management capability by defaultPriority MEDIUM 40
- TI-2026-30868 Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Remote Code Execution via Jolokia addNetworkConnectorPriority LOW 39
- Release ·
Apache ActiveMQ All, Apache ActiveMQ Broker 5.19.7, 6.2.6
4 records Highest priority Priority MEDIUM 1 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2026-33275 Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Jolokia `addNetworkConnector` Discovery Wrapper BypassPriority MEDIUM 41
- TI-2026-30868 Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Remote Code Execution via Jolokia addNetworkConnectorPriority LOW 39
- TI-2026-36462 Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All: Durable Subscription…Priority LOW 27
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat AMQ Broker 7 | Affected | No fix yet: Fix deferred |
| Red Hat AMQ Clients | Affected | No fix yet: Fix deferred |
| Red Hat Data Grid 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Fuse 7 | Affected | No fix yet: Fix deferred |
| Red Hat JBoss Enterprise Application Platform 7 | Affected | No fix yet: Fix deferred |
| Red Hat JBoss Enterprise Application Platform 8 | Affected | No fix yet: Fix deferred |
| Red Hat Satellite 6 | Affected | No fix yet: Fix deferred |
| Red Hat Single Sign-On 7 | Affected | No fix yet: Fix deferred |
| Red Hat build of Apache Camel for Spring Boot 4 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-46605
- 2026-10-03 Alias added: GHSA-cpw7-g3p5-qrfq
References
More Apache Activemq vulnerabilities
- TI-2023-25106 Deserialization of untrusted data in Apache ActiveMQ KEVCVSS 3.1CRITICAL 10.0
- TI-2016-02587 The Fileserver web application in Apache ActiveMQ 5.x before 5.14.0 allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-26494 Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Authenticated users could perform RCE via Jolokia MBeans KEVCVSS 3.1HIGH 8.8
- TI-2013-05951 Xstream API versions up to 1.4.6 and version 1.4.10, if the security framework has not… CVSS 3.1CRITICAL 9.8
- TI-2021-04451 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.1
- TI-2021-04446 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-46605 · CVE Program
- CVE-2026-46605 · NVD
- FIRST EPSS
- GHSA-cpw7-g3p5-qrfq · GitHub Advisory Database · CC BY 4.0
- CVE-2026-46605 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences