containerd user ID handling bypass allows runAsNonRoot evasion
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Privilege escalation, Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-269, CWE-843 and the CVSS impact.
Summary
containerd is an open-source container runtime. In versions prior to 1.7.32, 2.0.9, 2.2.4 and 2.3.1, containers launched with a numeric User directive that cannot be parsed as a 32-bit integer are incorrectly treated as a username, leading to runAsNonRoot evasion. If a crafted image provides an /etc/passwd file mapping this large numeric string to root, the container ultimately runs as root (UID 0). This allows the Kubernetes runAsNonRoot restriction to be bypassed, causing unexpected behavior for environments that require containers to run as a non-root user. This issue has been fixed in versions 1.7.32, 2.0.9, 2.2.4 and 2.3.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| backstage | containerd | before 1.7.32; 2.0.4 to before 2.0.9; 2.0.10 to before 2.2.4; 2.2.5 to before 2.3.1 | 1.7.32, 2.0.9, 2.2.4, 2.3.1 | Patch available | CNA |
| — | github.com/containerd/containerd (Go) | 1.7.27 to before 1.7.32 | 1.7.32 | Patch available | GHSA-fqw6-gf59-qr4w |
| — | github.com/containerd/containerd/v2 (Go) | 2.0.4 to before 2.0.9 | 2.0.9 | Patch available | GHSA-fqw6-gf59-qr4w |
| — | github.com/containerd/containerd/v2 (Go) | 2.1.0-beta.0 to before 2.2.4 | 2.2.4 | Patch available | GHSA-fqw6-gf59-qr4w |
| — | github.com/containerd/containerd/v2 (Go) | 2.3.0-beta.0 to before 2.3.1 | 2.3.1 | Patch available | GHSA-fqw6-gf59-qr4w |
- containerd Vendorbackstage Affected before 1.7.32; 2.0.4 to before 2.0.9; 2.0.10 to before 2.2.4; 2.2.5 to before 2.3.1 Fixed in 1.7.32, 2.0.9, 2.2.4, 2.3.1 Patch available CNA
- github.com/containerd/containerd (Go) Vendor— Affected 1.7.27 to before 1.7.32 Fixed in 1.7.32 Patch available GHSA-fqw6-gf59-qr4w
- github.com/containerd/containerd/v2 (Go) Vendor— Affected 2.0.4 to before 2.0.9 Fixed in 2.0.9 Patch available GHSA-fqw6-gf59-qr4w
- github.com/containerd/containerd/v2 (Go) Vendor— Affected 2.1.0-beta.0 to before 2.2.4 Fixed in 2.2.4 Patch available GHSA-fqw6-gf59-qr4w
- github.com/containerd/containerd/v2 (Go) Vendor— Affected 2.3.0-beta.0 to before 2.3.1 Fixed in 2.3.1 Patch available GHSA-fqw6-gf59-qr4w
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:linuxfoundation:containerd:*:*:*:*:*:*:*:* | 1.7.27 to before 1.7.32; 2.0.4 to before 2.0.9; 2.1.0 to before 2.2.4; 2.3.0 to before 2.3.1 | Vulnerable | backstage |
- cpe:2.3:a:linuxfoundation:containerd:*:*:*:*:*:*:*:* Versions 1.7.27 to before 1.7.32; 2.0.4 to before 2.0.9; 2.1.0 to before 2.2.4; 2.3.0 to before 2.3.1 Vulnerable ·backstage
Remediation
- Fix · CNA containerd (containerd) Fixed in 1.7.32, 2.0.9, 2.2.4, 2.3.1
- Fix · GHSA-fqw6-gf59-qr4w github.com/containerd/containerd (Go) Fixed in 1.7.32 Advisory →
- Fix · GHSA-fqw6-gf59-qr4w github.com/containerd/containerd/v2 (Go) Fixed in 2.0.9 Advisory →
- Fix · GHSA-fqw6-gf59-qr4w github.com/containerd/containerd/v2 (Go) Fixed in 2.2.4 Advisory →
- Fix · GHSA-fqw6-gf59-qr4w github.com/containerd/containerd/v2 (Go) Fixed in 2.3.1 Advisory →
Red Hat 1 advisory
- RHSA-2026:35111 Released 2026-07-02 · Red Hat rating ImportantRed Hat Hardened Images RPMs Security Update
- Red Hat Hardened Images trivy-0.72.0-0.1.hum1@aarch64, trivy-0.72.0-0.1.hum1@src, trivy-0.72.0-0.1.hum1@x86_64
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Hardened Images | Fixed | RHSA-2026:35111 |
Not affected: 42 products
- Assisted Installer for Red Hat OpenShift Container Platform 2
- Confidential Compute Attestation
- Deployment Validation Operator
- Gatekeeper 3
- Kernel Module Management Operator for Red Hat Openshift
- Logging Subsystem for Red Hat OpenShift
- Logical Volume Manager Storage
- MCP Server for Red Hat OpenShift
- Machine Deletion Remediation Operator
- Migration Toolkit for Containers
- Migration Toolkit for Virtualization
- Multicluster Engine for Kubernetes
- Multicluster Global Hub
- Node HealthCheck Operator
- OpenShift API for Data Protection
- OpenShift Developer Tools and Services
- OpenShift Lightspeed
- OpenShift Pipelines
- OpenShift Serverless
- OpenShift Service Mesh 2
- OpenShift Service Mesh 3
- Pen Drive Powered by Red Hat Lightspeed
- Power monitoring for Red Hat OpenShift
- Red Hat Advanced Cluster Management for Kubernetes 2
- Red Hat Advanced Cluster Security 4
- Red Hat Ansible Automation Platform 2
- Red Hat Build of Kueue
- Red Hat Ceph Storage 6
- Red Hat Ceph Storage 9
- Red Hat OpenShift AI (RHOAI)
- Red Hat OpenShift Container Platform 4
- Red Hat OpenShift Container Platform 5
- Red Hat OpenShift Dev Spaces
- Red Hat OpenShift GitOps
- Red Hat OpenShift Virtualization 4
- Red Hat OpenShift for Windows Containers
- Red Hat OpenStack Platform 16.2
- Red Hat OpenStack Platform 17.1
- Red Hat OpenStack Platform 18.0
- Red Hat Openshift Data Foundation 4
- Red Hat Trusted Artifact Signer
- Red Hat Trusted Profile Analyzer
Timeline
- 2026-10-02 Threatist record created from CVE-2026-46680
- 2026-10-03 Alias added: GHSA-fqw6-gf59-qr4w
- 2026-11-05 Affected versions changed · Red Hat
References
More backstage Containerd vulnerabilities
- TI-2021-19622 Improper Preservation of Permissions in containerd CVSS 3.1CRITICAL 9.1
- TI-2023-10635 containerd supplementary groups are not set up properly CVSS 3.1HIGH 7.8
- TI-2022-07700 Insecure handling of image volumes in containerd CRI plugin CVSS 3.1HIGH 7.5
- TI-2026-38567 Improper input validation in backstage containerd CVSS 4.0CRITICAL 9.4
- TI-2026-38569 containerd CRI checkpoint restore CDI annotation smuggling CVSS 4.0HIGH 8.4
- TI-2025-29820 Containerd vulnerable to host filesystem access during image unpack CVSS 4.0HIGH 7.6
Sources
- CVE-2026-46680 · CVE Program
- CVE-2026-46680 · NVD
- FIRST EPSS
- GHSA-fqw6-gf59-qr4w · GitHub Advisory Database · CC BY 4.0
- CVE-2026-46680 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences