Improper input validation in Apache Camel
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat.
Summary
Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection'), Improper Input Validation, Server-Side Request Forgery (SSRF) vulnerability in Apache Camel Solr component. The camel-solr producer copies Exchange message headers whose names begin with the SolrParam. prefix into the parameters of the Solr request, and headers whose names begin with the SolrField. prefix into the fields of the indexed Solr document. The prefix constants (SolrConstants.HEADER_PARAM_PREFIX / HEADER_FIELD_PREFIX) were the plain strings SolrParam. / SolrField.. Because these names do not start with the Camel / camel prefix, HttpHeaderFilterStrategy - which blocks only the Camel header namespace on the HTTP boundary - let them pass from an inbound HTTP request straight into the Exchange. In a route that bridges an HTTP consumer (for example platform-http) into a solr: producer, any HTTP client could therefore set SolrParam.* headers to inject arbitrary Solr request parameters - including shards or stream.url, which cause the Solr server to issue server-side requests to an attacker-chosen URL (server-side request forgery, for example to an internal service or a cloud metadata endpoint), or qt to reach administrative request handlers - and set SolrField.* headers to inject arbitrary fields into indexed documents. No credentials are required when the bridging consumer is unauthenticated. This issue affects Apache Camel: from 4.0.0 before 4.14.8, from 4.15.0 before 4.18.3, from 4.19.0 before 4.21.0. Users are recommended to upgrade to version 4.21.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.8. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.3. After upgrading, routes that set Solr parameters or fields via the raw header prefixes must use CamelSolrParam. / CamelSolrField. instead of SolrParam. / SolrField.. For deployments that cannot upgrade immediately, strip the SolrParam.* and SolrField.* headers from any untrusted ingress before the solr: producer, and set the required Solr parameters and fields from a trusted source in the route.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Camel | 4.0.0 to before 4.14.8; 4.15.0 to before 4.18.3; 4.19.0 to before 4.21.0 | 4.14.8, 4.18.3, 4.21.0 | Patch available | CNA |
| — | org.apache.camel:camel-solr (Maven) | 4.0.0 to before 4.14.8 | 4.14.8 | Patch available | GHSA-4h4f-v54q-7pq8 |
| — | org.apache.camel:camel-solr (Maven) | 4.15.0 to before 4.18.3 | 4.18.3 | Patch available | GHSA-4h4f-v54q-7pq8 |
| — | org.apache.camel:camel-solr (Maven) | 4.19.0 to before 4.21.0 | 4.21.0 | Patch available | GHSA-4h4f-v54q-7pq8 |
- Apache Camel VendorApache Affected 4.0.0 to before 4.14.8; 4.15.0 to before 4.18.3; 4.19.0 to before 4.21.0 Fixed in 4.14.8, 4.18.3, 4.21.0 Patch available CNA
- org.apache.camel:camel-solr (Maven) Vendor— Affected 4.0.0 to before 4.14.8 Fixed in 4.14.8 Patch available GHSA-4h4f-v54q-7pq8
- org.apache.camel:camel-solr (Maven) Vendor— Affected 4.15.0 to before 4.18.3 Fixed in 4.18.3 Patch available GHSA-4h4f-v54q-7pq8
- org.apache.camel:camel-solr (Maven) Vendor— Affected 4.19.0 to before 4.21.0 Fixed in 4.21.0 Patch available GHSA-4h4f-v54q-7pq8
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:camel:*:*:*:*:*:*:*:* | 4.0.0 to before 4.14.8; 4.15.0 to before 4.18.3; 4.19.0 to before 4.21.0 | Vulnerable | Apache |
- cpe:2.3:a:apache:camel:*:*:*:*:*:*:*:* Versions 4.0.0 to before 4.14.8; 4.15.0 to before 4.18.3; 4.19.0 to before 4.21.0 Vulnerable ·Apache
Remediation
- Fix · CNA Apache Camel (Apache Software Foundation) Fixed in 4.14.8, 4.18.3, 4.21.0
- Fix · GHSA-4h4f-v54q-7pq8 org.apache.camel:camel-solr (Maven) Fixed in 4.14.8 Advisory →
- Fix · GHSA-4h4f-v54q-7pq8 org.apache.camel:camel-solr (Maven) Fixed in 4.18.3 Advisory →
- Fix · GHSA-4h4f-v54q-7pq8 org.apache.camel:camel-solr (Maven) Fixed in 4.21.0 Advisory →
Red Hat 1 advisory
- RHSA-2026:71675 Released 2026-09-24 · Red Hat rating ImportantRed Hat Build of Apache Camel 4.18.4 for Spring Boot release.
- Red Hat build of Apache Camel 4.18.4 for Spring Boot 3.5.16
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apache Camel 4.14.8, 4.18.3, 4.21.0
14 records Highest priority Priority MEDIUM 7 MEDIUM, 7 LOW
Other records, highest priority first
- TI-2026-35614 Improper input validation in Apache CamelPriority MEDIUM 50
- TI-2026-34159 Improper input validation in Apache CamelPriority MEDIUM 50
- TI-2026-34157 Improper input validation in Apache CamelPriority MEDIUM 50
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat build of Apache Camel 4.18.4 for Spring Boot 3.5.16 | Fixed | RHSA-2026:71675 |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-48203
- 2026-10-03 Alias added: GHSA-4h4f-v54q-7pq8
References
Advisory 3
Other 11
- https://github.com/apache/camel/pull/23410
- https://github.com/apache/camel/pull/23483
- https://github.com/apache/camel/pull/23489
- https://github.com/apache/camel/commit/4578a9014a6b7a914cf16baf2c5bf62a7b163a88
- https://github.com/apache/camel/commit/cfc0d51f015b3112eae4ce0968d045f00e95c796
- https://github.com/apache/camel/commit/f79cbe3f8bc3fe1095d8492e9ef321289451d457
- https://github.com/apache/camel
- https://github.com/apache/camel/releases/tag/camel-4.14.8
- https://github.com/apache/camel/releases/tag/camel-4.18.3
- https://github.com/apache/camel/releases/tag/camel-4.21.0
- https://issues.apache.org/jira/browse/CAMEL-23597
More Apache Camel vulnerabilities
- TI-2026-76322 Unsafe deserialization in Apache Camel camel-hazelcast CVSS 4.0CRITICAL 10.0
- TI-2026-18973 Apache Camel: Camel-Keycloak: Cross-Realm Token Acceptance Bypass in KeycloakSecurityPolicy CVSS 3.1CRITICAL 9.1
- TI-2026-76339 Path traversal in Apache Camel azure-files component CVSS 3.1CRITICAL 9.1
- TI-2026-76330 Path traversal in Apache Camel FTP consumer escapes polled directory CVSS 3.1CRITICAL 9.1
- TI-2025-20435 Apache Camel: Camel Message Header Injection via Improper Filtering CVSS 3.1MEDIUM 5.6
- TI-2026-34899 Apache Camel: Camel-CXF Message Header Injection via Missing Inbound Filtering CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-48203 · CVE Program
- CVE-2026-48203 · NVD
- FIRST EPSS
- GHSA-4h4f-v54q-7pq8 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-48203 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences