Improper input validation in Apache Camel
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
Improper Input Validation, Improper Access Control vulnerability in Apache Camel in Camel Mongodb Gridfs component. The camel-mongodb-gridfs producer selects the GridFS operation to perform from the gridfs.operation Exchange header when the endpoint's operation parameter is not set - which is the default. The control-header constants (GridFsConstants.GRIDFS_OPERATION, GRIDFS_OBJECT_ID, GRIDFS_METADATA, GRIDFS_CHUNKSIZE, GRIDFS_FILE_ID_PRODUCED) were the plain strings gridfs.operation, gridfs.objectid, gridfs.metadata, gridfs.chunksize and gridfs.fileid. Because these names do not start with the Camel / camel prefix, HttpHeaderFilterStrategy - which blocks only the Camel header namespace on the HTTP boundary - let them pass from an inbound HTTP request straight into the Exchange. In a route that bridges an HTTP consumer (for example platform-http) into a mongodb-gridfs: producer with no explicit operation, any HTTP client could therefore set the gridfs.operation header to override the route's intended operation - switching, for example, a file upload to remove (deleting a file identified by the attacker-supplied gridfs.objectid), listAll (enumerating every file in the bucket) or findOne (reading a file) - and supply a gridfs.metadata value that is parsed as a MongoDB document, enabling NoSQL operator injection. No credentials are required when the bridging consumer is unauthenticated. This issue affects Apache Camel: from 4.0.0 before 4.14.8, from 4.15.0 before 4.18.3, from 4.19.0 before 4.21.0. Users are recommended to upgrade to version 4.21.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.8. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.3. After upgrading, routes that drive GridFS operations or metadata via the raw header names must use CamelGridFsOperation / CamelGridFsObjectId / CamelGridFsMetadata / CamelGridFsChunkSize / CamelGridFsFileId instead of the gridfs.* names. For deployments that cannot upgrade immediately, set an explicit operation on the mongodb-gridfs: endpoint so the operation is not taken from a header, and strip the gridfs.* headers from any untrusted ingress before the producer.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Camel | 4.0.0 to before 4.14.8; 4.15.0 to before 4.18.3; 4.19.0 to before 4.21.0 | 4.14.8, 4.18.3, 4.21.0 | Patch available | CNA |
| — | org.apache.camel:camel-mongodb-gridfs (Maven) | 4.0.0 to before 4.14.8 | 4.14.8 | Patch available | GHSA-f7g3-2cg6-f5hj |
| — | org.apache.camel:camel-mongodb-gridfs (Maven) | 4.15.0 to before 4.18.3 | 4.18.3 | Patch available | GHSA-f7g3-2cg6-f5hj |
| — | org.apache.camel:camel-mongodb-gridfs (Maven) | 4.19.0 to before 4.21.0 | 4.21.0 | Patch available | GHSA-f7g3-2cg6-f5hj |
- Apache Camel VendorApache Affected 4.0.0 to before 4.14.8; 4.15.0 to before 4.18.3; 4.19.0 to before 4.21.0 Fixed in 4.14.8, 4.18.3, 4.21.0 Patch available CNA
- org.apache.camel:camel-mongodb-gridfs (Maven) Vendor— Affected 4.0.0 to before 4.14.8 Fixed in 4.14.8 Patch available GHSA-f7g3-2cg6-f5hj
- org.apache.camel:camel-mongodb-gridfs (Maven) Vendor— Affected 4.15.0 to before 4.18.3 Fixed in 4.18.3 Patch available GHSA-f7g3-2cg6-f5hj
- org.apache.camel:camel-mongodb-gridfs (Maven) Vendor— Affected 4.19.0 to before 4.21.0 Fixed in 4.21.0 Patch available GHSA-f7g3-2cg6-f5hj
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:camel:*:*:*:*:*:*:*:* | 4.0.0 to before 4.14.8; 4.15.0 to before 4.18.3; 4.19.0 to before 4.21.0 | Vulnerable | Apache |
- cpe:2.3:a:apache:camel:*:*:*:*:*:*:*:* Versions 4.0.0 to before 4.14.8; 4.15.0 to before 4.18.3; 4.19.0 to before 4.21.0 Vulnerable ·Apache
Remediation
- Fix · CNA Apache Camel (Apache Software Foundation) Fixed in 4.14.8, 4.18.3, 4.21.0
- Fix · GHSA-f7g3-2cg6-f5hj org.apache.camel:camel-mongodb-gridfs (Maven) Fixed in 4.14.8 Advisory →
- Fix · GHSA-f7g3-2cg6-f5hj org.apache.camel:camel-mongodb-gridfs (Maven) Fixed in 4.18.3 Advisory →
- Fix · GHSA-f7g3-2cg6-f5hj org.apache.camel:camel-mongodb-gridfs (Maven) Fixed in 4.21.0 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apache Camel 4.14.8, 4.18.3, 4.21.0
14 records Highest priority Priority MEDIUM 7 MEDIUM, 7 LOW
Other records, highest priority first
- TI-2026-34159 Improper input validation in Apache CamelPriority MEDIUM 50
- TI-2026-34157 Improper input validation in Apache CamelPriority MEDIUM 50
- TI-2026-35613 Improper input validation in Apache CamelPriority MEDIUM 48
Timeline
- 2026-10-02 Threatist record created from CVE-2026-48204
- 2026-10-03 Alias added: GHSA-f7g3-2cg6-f5hj
References
Advisory 3
More Apache Camel vulnerabilities
- TI-2026-76322 Unsafe deserialization in Apache Camel camel-hazelcast CVSS 4.0CRITICAL 10.0
- TI-2026-18973 Apache Camel: Camel-Keycloak: Cross-Realm Token Acceptance Bypass in KeycloakSecurityPolicy CVSS 3.1CRITICAL 9.1
- TI-2026-76339 Path traversal in Apache Camel azure-files component CVSS 3.1CRITICAL 9.1
- TI-2026-76330 Path traversal in Apache Camel FTP consumer escapes polled directory CVSS 3.1CRITICAL 9.1
- TI-2025-20435 Apache Camel: Camel Message Header Injection via Improper Filtering CVSS 3.1MEDIUM 5.6
- TI-2026-34899 Apache Camel: Camel-CXF Message Header Injection via Missing Inbound Filtering CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-48204 · CVE Program
- CVE-2026-48204 · NVD
- FIRST EPSS
- GHSA-f7g3-2cg6-f5hj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences