Format Plugins | Heap-based Buffer Overflow (CWE-122)
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-122 and the CVSS impact.
Summary
Format Plugins versions 1.1.2 and earlier are affected by a Heap-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Format Plugins (Adobe) Fixed in 1.1.3
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Adobe Format Plugins — helpx.adobe.com/security/products/formatplugins/apsb26-65.h…
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-35698 Format Plugins | Heap-based Buffer Overflow (CWE-122)Priority LOW 36
Timeline
- 2026-10-02 Threatist record created from CVE-2026-48291
- 2026-10-03 Alias added: GHSA-rf2g-jcmc-354j
References
More Adobe Format Plugins vulnerabilities
- TI-2026-35777 Format Plugins | Heap-based Buffer Overflow (CWE-122) CVSS 3.1HIGH 7.8
- TI-2026-35698 Format Plugins | Heap-based Buffer Overflow (CWE-122) CVSS 3.1HIGH 7.8
- TI-2025-38227 Format Plugins | Out-of-bounds Read (CWE-125) CVSS 3.1HIGH 7.8
- TI-2025-38226 Format Plugins | Heap-based Buffer Overflow (CWE-122) CVSS 3.1HIGH 7.8
- TI-2025-38225 Format Plugins | Heap-based Buffer Overflow (CWE-122) CVSS 3.1HIGH 7.8
- TI-2025-38233 Format Plugins | Out-of-bounds Read (CWE-125) CVSS 3.1MEDIUM 5.5
Sources
- CVE-2026-48291 · CVE Program
- CVE-2026-48291 · NVD
- FIRST EPSS
- GHSA-rf2g-jcmc-354j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences