OS command injection in browserstack-cypress-cli
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-78.
Summary
The browserstack-cypress-cli is BrowserStack's CLI which allows users to run Cypress tests on BrowserStack. Versions prior to 1.36.4 are vulnerable to OS command injection via the cypress_config_file configuration parameter. In readCypressConfigUtil.js, the loadJsFile() function constructs a shell command by interpolating the user-controlled cypress_config_filepath value into a template literal, then executes it via child_process.execSync(). Shell metacharacters in the config path (specifically " and ;) allow breaking out of the quoted argument and injecting arbitrary commands. This issue has been fixed in version 1.36.6.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| browserstack | browserstack-cypress-cli | before 1.36.6 | 1.36.6 | Patch available | CNA |
- browserstack-cypress-cli Vendorbrowserstack Affected before 1.36.6 Fixed in 1.36.6 Patch available CNA
Remediation
- Fix · CNA browserstack-cypress-cli (browserstack) Fixed in 1.36.6
Timeline
- 2026-10-02 Threatist record created from CVE-2026-48723
- 2026-10-25 EPSS moved to the below the 50th percentile
References
More browserstack vulnerabilities
- TI-2026-36356 BrowserStack Runner 0.9.5 Unauthenticated RCE via /_log HTTP Handler CVSS 4.0HIGH 8.7
- TI-2026-36357 BrowserStack Runner 0.9.5 Path Traversal via _default HTTP Handler CVSS 4.0HIGH 7.1
- TI-2025-35496 The Node.js package browserstack-local 1.5.8 contains a command injection vulnerability. CVSS 3.1HIGH 7.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences