Cross-site request forgery in Jenkins GitHub Integration Plugin
Priority LOW 19CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
A cross-site request forgery (CSRF) vulnerability in Jenkins GitHub Integration Plugin 0.7.3 and earlier allows attackers to attackers to trigger a build for a pull request.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00105 1st percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:github-integration-parent (Maven): 0.7.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins GitHub Integration Plugin | up to 0.7.3 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:github-integration-parent (Maven) | before 0.7.4 | 0.7.4 | Patch available | GHSA-rf8w-7c3g-7h3g |
- Jenkins GitHub Integration Plugin VendorJenkins Affected up to 0.7.3 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:github-integration-parent (Maven) Vendor— Affected before 0.7.4 Fixed in 0.7.4 Patch available GHSA-rf8w-7c3g-7h3g
Remediation
- Fix · GHSA-rf8w-7c3g-7h3g org.jenkins-ci.plugins:github-integration-parent (Maven) Fixed in 0.7.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-48925
- 2026-10-03 Alias added: GHSA-rf8w-7c3g-7h3g
References
More Jenkins vulnerabilities
- TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
Sources
- CVE-2026-48925 · CVE Program
- CVE-2026-48925 · NVD
- FIRST EPSS
- GHSA-rf8w-7c3g-7h3g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences