OPNsense < 26.1.9 Stored XSS via Firewall Rule Description Field
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
OPNsense before 26.1.9 contains a stored cross-site scripting vulnerability that allows authenticated attackers with firewall rule management privileges to inject arbitrary HTML or JavaScript by embedding payloads in the firewall rule description field via the filter API endpoint. The unsanitized description value is persisted and later rendered through the default cell formatter in opnsense_bootgrid.js, which assigns raw cell content to innerHTML, causing injected scripts to execute in the browser of any authenticated user who views the Firewall Rules page, enabling session hijacking or credential theft.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Deciso B.V. | OPNsense | before 26.1.9 | 26.1.9 | Patch available | CNA |
- OPNsense VendorDeciso B.V. Affected before 26.1.9 Fixed in 26.1.9 Patch available CNA
Remediation
- Fix · CNA OPNsense (Deciso B.V.) Fixed in 26.1.9
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Deciso B.V. OPNsense 26.1.9
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-36347 OPNsense < 26.1.9 Stored XSS via Certificate Description FieldPriority LOW 22
Timeline
- 2026-10-02 Threatist record created from CVE-2026-49131
- 2026-10-03 Alias added: GHSA-2wfc-8j3p-p6cp
References
Patch 1
Other 1
More Deciso B.V. vulnerabilities
- TI-2026-36347 OPNsense < 26.1.9 Stored XSS via Certificate Description Field CVSS 4.0MEDIUM 5.1
Sources
- CVE-2026-49131 · CVE Program
- CVE-2026-49131 · NVD
- FIRST EPSS
- GHSA-2wfc-8j3p-p6cp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences