Apache ActiveMQ: Authenticated web users retain admin access by default in the Web Console
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-285.
Summary
Improper Authorization vulnerability in Apache ActiveMQ. An authenticated low-privilege Web Console user by default can access /admin/* paths in the Web Console. The default Jetty settings incorrectly did not limit those paths to only admins. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache ActiveMQ | before 5.19.8; 6.0.0 to before 6.2.7 | 5.19.8, 6.2.7 | Patch available | CNA |
| — | org.apache.activemq:apache-activemq (Maven) | before 5.19.8 | 5.19.8 | Patch available | GHSA-f892-4h9f-j7g9 |
| — | org.apache.activemq:apache-activemq (Maven) | 6.0.0 to before 6.2.7 | 6.2.7 | Patch available | GHSA-f892-4h9f-j7g9 |
- Apache ActiveMQ VendorApache Affected before 5.19.8; 6.0.0 to before 6.2.7 Fixed in 5.19.8, 6.2.7 Patch available CNA
- org.apache.activemq:apache-activemq (Maven) Vendor— Affected before 5.19.8 Fixed in 5.19.8 Patch available GHSA-f892-4h9f-j7g9
- org.apache.activemq:apache-activemq (Maven) Vendor— Affected 6.0.0 to before 6.2.7 Fixed in 6.2.7 Patch available GHSA-f892-4h9f-j7g9
Remediation
- Fix · CNA Apache ActiveMQ (Apache Software Foundation) Fixed in 5.19.8, 6.2.7
- Fix · GHSA-f892-4h9f-j7g9 org.apache.activemq:apache-activemq (Maven) Fixed in 5.19.8 Advisory →
- Fix · GHSA-f892-4h9f-j7g9 org.apache.activemq:apache-activemq (Maven) Fixed in 6.2.7 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apache ActiveMQ 5.19.8, 6.2.7
9 records Highest priority Priority MEDIUM 7 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2026-39329 Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Temporary destination ownership takeoverPriority MEDIUM 40
- TI-2026-38893 Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Client, Apache ActiveMQ Broker…Priority MEDIUM 40
- TI-2026-38892 Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp: Unbounded header buffer in STOMP NIO codecPriority MEDIUM 40
Timeline
- 2026-10-02 Threatist record created from CVE-2026-49877
- 2026-10-03 Alias added: GHSA-f892-4h9f-j7g9
- 2026-11-04 Fix available: Maven/org.apache.activemq:[email protected], Maven/org.apache.activemq:[email protected] · GHSA-f892-4h9f-j7g9
- 2026-11-04 CVSS score added · GHSA-f892-4h9f-j7g9
- 2026-11-04 Weakness changed · GHSA-f892-4h9f-j7g9
- 2026-11-04 10 new references · GHSA-f892-4h9f-j7g9
References
Advisory 3
Other 7
- https://github.com/apache/activemq/pull/2074
- https://github.com/apache/activemq/commit/085efea55270aca20f2158c0a91a0f4a9fe497f4
- https://github.com/apache/activemq/commit/1eda6a164f38b6eb1a90ffb1462a95cd9ad121e9
- https://github.com/apache/activemq/commit/be70a7efa1efcb6bdb9988f736245b06d39a91e4
- https://github.com/apache/activemq
- https://github.com/apache/activemq/releases/tag/activemq-5.19.8
- https://github.com/apache/activemq/releases/tag/activemq-6.2.7
More Apache Activemq vulnerabilities
- TI-2023-25106 Deserialization of untrusted data in Apache ActiveMQ KEVCVSS 3.1CRITICAL 10.0
- TI-2016-02587 The Fileserver web application in Apache ActiveMQ 5.x before 5.14.0 allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-26494 Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Authenticated users could perform RCE via Jolokia MBeans KEVCVSS 3.1HIGH 8.8
- TI-2013-05951 Xstream API versions up to 1.4.6 and version 1.4.10, if the security framework has not… CVSS 3.1CRITICAL 9.8
- TI-2021-04451 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.1
- TI-2021-04446 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-49877 · CVE Program
- CVE-2026-49877 · NVD
- FIRST EPSS
- GHSA-f892-4h9f-j7g9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences