Read the docs
TI-2026-37811 Aliases CVE-2026-52684GHSA-j58f-rgm2-v2p8

Prefetch Feature Allows Persistent Ghost Domain Cache Poisoning Attack

Priority LOW 17Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA.

Summary

If the auth responds very slowly and the records expire in between, the capping of TTLs is not enforced for lack of data. This does not happen on regular resolve as then then the child records are used immediately if not expired and thus valid, or the records are expired, and in that case not used. So this case can only happen if almost expired records are used to refresh the authoritative NS records.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00225 13th percentileScored 2026-11-07
Fix Fixed Recursor (PowerDNS): 5.5.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PowerDNSRecursor0.0.0 to before 5.5.05.5.0Patch availableCNA
  • Recursor VendorPowerDNS Affected 0.0.0 to before 5.5.0 Fixed in 5.5.0 Patch available CNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:powerdns:recursor:*:*:*:*:*:*:*:*——PowerDNS
  • cpe:2.3:a:powerdns:recursor:*:*:*:*:*:*:*:* Versions — — ·PowerDNS

Remediation

  • Fix · CNA Recursor (PowerDNS) Fixed in 5.5.0

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-52684
  2. 2026-10-03 Alias added: GHSA-j58f-rgm2-v2p8

References

  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2015-01678 The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and… CVSS 2.0HIGH 7.8
  • TI-2021-14878 PowerDNS Authoritative Server 4.5.0 before 4.5.1 allows anybody to crash the process by… CVSS 3.1HIGH 7.5
  • TI-2016-04703 PowerDNS (aka pdns) Authoritative Server before 3.4.10 does not properly handle a . CVSS 3.0HIGH 7.5
  • TI-2018-12065 Out-of-bounds read in [UNKNOWN] pdns-recursor CVSS 3.0HIGH 7.5
See all 130 →

Sources