RRSIGs with too few labels can lead to bypass of DNSSEC wildcard validation
Priority LOW 38CWE-295Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Spoofing, Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-295 and CWE-345.
Summary
RRSIGs with too few labels can lead to bypass of DNSSEC wildcard validation
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00176 7th percentileScored 2026-11-07
Fix Fixed Recursor (PowerDNS): 5.2.12, 5.3.9, 5.4.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PowerDNS | Recursor | 5.2.0 to before 5.2.12; 5.3.0 to before 5.3.9; 5.4.0 to before 5.4.4 | 5.2.12, 5.3.9, 5.4.4 | Patch available | CNA |
- Recursor VendorPowerDNS Affected 5.2.0 to before 5.2.12; 5.3.0 to before 5.3.9; 5.4.0 to before 5.4.4 Fixed in 5.2.12, 5.3.9, 5.4.4 Patch available CNA
Remediation
- Fix · CNA Recursor (PowerDNS) Fixed in 5.2.12, 5.3.9, 5.4.4
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
PowerDNS Recursor 5.2.12, 5.3.9, 5.4.4
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-37812 Wildcard CNAME proof validation bypassPriority LOW 17
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-52688
- 2026-10-03 Alias added: GHSA-q3h2-8p56-9cg6
References
More PowerDNS vulnerabilities
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2015-01678 The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and… CVSS 2.0HIGH 7.8
- TI-2021-14878 PowerDNS Authoritative Server 4.5.0 before 4.5.1 allows anybody to crash the process by… CVSS 3.1HIGH 7.5
- TI-2016-04703 PowerDNS (aka pdns) Authoritative Server before 3.4.10 does not properly handle a . CVSS 3.0HIGH 7.5
- TI-2018-12065 Out-of-bounds read in [UNKNOWN] pdns-recursor CVSS 3.0HIGH 7.5
Sources
- CVE-2026-52688 · CVE Program
- CVE-2026-52688 · NVD
- FIRST EPSS
- GHSA-q3h2-8p56-9cg6 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-52688 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences