Read the docs
TI-2026-38522 Aliases CVE-2026-53440GHSA-92m7-4fpw-2wxm

Open redirect in Jenkins

Priority LOW 19CWE-601Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Spoofing
Confidentiality · integrity · availability
None · Low · None
Fix status
Partial Red Hat: 1 without a fix

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-601.

Summary

Jenkins 2.567 and earlier, LTS 2.555.2 and earlier does not ensure that the "from" parameter in the "Delegate to servlet container" security realm is safe to redirect to after login, allowing attackers to perform phishing attacks by redirecting users to an attacker-controlled domain.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00211 11th percentileScored 2026-11-07
Fix Partial Jenkins (Jenkins Project): 2.568, 2.555.3org.jenkins-ci.main:jenkins-core (Maven): 2.555.3, 2.568Red Hat: 1 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins—2.568, 2.555.3Patch availableCNA
—org.jenkins-ci.main:jenkins-core (Maven)before 2.555.32.555.3Patch availableGHSA-92m7-4fpw-2wxm
—org.jenkins-ci.main:jenkins-core (Maven)2.556 to before 2.5682.568Patch availableGHSA-92m7-4fpw-2wxm
  • Jenkins VendorJenkins Affected — Fixed in 2.568, 2.555.3 Patch available CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.555.3 Fixed in 2.555.3 Patch available GHSA-92m7-4fpw-2wxm
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.556 to before 2.568 Fixed in 2.568 Patch available GHSA-92m7-4fpw-2wxm

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*before 2.555.3VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:*before 2.568VulnerableJenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions before 2.555.3 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:* Versions before 2.568 Vulnerable ·Jenkins

Remediation

  • Fix · CNA Jenkins (Jenkins Project) Fixed in 2.568, 2.555.3
  • Fix · GHSA-92m7-4fpw-2wxm org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.555.3 Advisory →
  • Fix · GHSA-92m7-4fpw-2wxm org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.568 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    Jenkins — Jenkins Security Advisory 2026-06-10

    8 records Highest priority Priority HIGH 1 HIGH, 7 LOW

    Other records, highest priority first

    • TI-2026-38517 Deserialization of untrusted data in JenkinsPriority HIGH 72
    • TI-2026-38523 Cross-site scripting in JenkinsPriority LOW 24
    • TI-2026-38524 Jenkins 2.567 and earlier, LTS 2.555.2 and earlier does not encrypt secrets from POST…Priority LOW 23

Vendor assessments

Red Hat

Red Hat rating: Low. Red Hat's page for this CVE →

ProductStatusPlan or fix
OpenShift Developer Tools and ServicesAffectedNo fix yet: Fix deferred

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-53440
  2. 2026-10-03 Alias added: GHSA-92m7-4fpw-2wxm

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources