Envoy Gateway: Authentication Bypass via Improper Input Validation in EnvoyExtensionPolicy Lua Allows Secret Disclosure
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Envoy Gateway is an open source project for managing Envoy Proxy as a standalone or Kubernetes-based application gateway. Prior to 1.7.4 and 1.8.1, to_absolute_normalized_path in internal/gatewayapi/luavalidator/security.lua does not collapse redundant separators before is_critical_path evaluates Lua submitted through EnvoyExtensionPolicy during default Strict validation. Linux resolves a double-slash absolute path as the corresponding single-slash path, but the validator does not match the redundant-separator form, allowing submitted Lua to read arbitrary files from the gateway controller pod. Exposed files can include Kubernetes service-account tokens, TLS certificates, and process environment data, and the disclosed credentials can provide access to sensitive Kubernetes API Server or Gateway xDS server information. This issue is fixed in versions 1.7.4 and 1.8.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| envoyproxy | gateway | before 1.7.4; 1.8.0-rc.0 to before 1.8.1 | 1.7.4, 1.8.1 | Patch available | CNA |
| — | github.com/envoyproxy/gateway (Go) | 1.8.0-rc.0 to before 1.8.1 | 1.8.1 | Patch available | GHSA-wcrf-9vrr-854f |
| — | github.com/envoyproxy/gateway (Go) | before 1.7.4 | 1.7.4 | Patch available | GHSA-wcrf-9vrr-854f |
- gateway Vendorenvoyproxy Affected before 1.7.4; 1.8.0-rc.0 to before 1.8.1 Fixed in 1.7.4, 1.8.1 Patch available CNA
- github.com/envoyproxy/gateway (Go) Vendor— Affected 1.8.0-rc.0 to before 1.8.1 Fixed in 1.8.1 Patch available GHSA-wcrf-9vrr-854f
- github.com/envoyproxy/gateway (Go) Vendor— Affected before 1.7.4 Fixed in 1.7.4 Patch available GHSA-wcrf-9vrr-854f
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:envoyproxy:gateway:*:*:*:*:*:*:*:* | — | — | envoyproxy |
- cpe:2.3:a:envoyproxy:gateway:*:*:*:*:*:*:*:* Versions — — ·envoyproxy
Remediation
- Fix · CNA gateway (envoyproxy) Fixed in 1.7.4, 1.8.1
- Fix · GHSA-wcrf-9vrr-854f github.com/envoyproxy/gateway (Go) Fixed in 1.8.1 Advisory →
- Fix · GHSA-wcrf-9vrr-854f github.com/envoyproxy/gateway (Go) Fixed in 1.7.4 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Critical. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat Connectivity Link 1
Timeline
- 2026-10-02 Threatist record created from CVE-2026-53713
- 2026-10-03 Alias added: GHSA-wcrf-9vrr-854f
- 2026-10-09 Affected versions changed · Red Hat
- 2026-10-09 CVSS score added · Red Hat
- 2026-10-24 Affected versions changed · Red Hat
- 2026-11-02 Affected versions changed · Red Hat
References
Other 10
- https://github.com/envoyproxy/gateway/security/advisories/GHSA-wcrf-9vrr-854f
- https://github.com/envoyproxy/gateway/pull/9171
- https://github.com/envoyproxy/gateway/pull/9172
- https://github.com/envoyproxy/gateway/pull/9173
- https://github.com/envoyproxy/gateway/commit/5a78db82b7cf4fc5bebbeda2c50952892038a464
- https://github.com/envoyproxy/gateway/commit/96e2b750868a459ace4b8b68e6a6e4fb0152b9b7
- https://github.com/envoyproxy/gateway/commit/b4737180c7e597490c6363075c565fa8cf24eead
- https://github.com/envoyproxy/gateway/releases/tag/v1.7.4
- https://github.com/envoyproxy/gateway/releases/tag/v1.8.1
- https://github.com/envoyproxy/gateway
More envoyproxy vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-20001 HTTP/2: CPU exhaustion due to CONTINUATION frame flood CVSS 3.1HIGH 7.5
- TI-2024-18524 HTTP/2: memory exhaustion due to CONTINUATION frame flood CVSS 3.1HIGH 7.5
- TI-2023-12215 Envoy client may fake the header `x-envoy-original-path` CVSS 3.1CRITICAL 9.1
- TI-2023-18002 Envoy vulnerable to OAuth2 credentials exploit with permanent validity CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-53713 · CVE Program
- CVE-2026-53713 · NVD
- FIRST EPSS
- GHSA-wcrf-9vrr-854f · GitHub Advisory Database · CC BY 4.0
- CVE-2026-53713 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences