Read the docs
TI-2026-39141 Aliases CVE-2026-54239

FaustWP — Authentication Bypass via Initialization Vector Modification in Token Envelope

Priority MEDIUM 40CWE-345Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-345.

Summary

Faust.js is a headless WordPress toolkit. Prior to 1.8.11, the FaustWP WordPress plugin authenticates only the ciphertext in its token envelope and excludes the 16-byte initialization vector from the HMAC in WPE\FaustWP\Auth\encrypt() and WPE\FaustWP\Auth\decrypt() in plugins/faustwp/includes/auth/functions.php. A logged-in non-administrator who obtains an authorization code from GET /generate can modify the unauthenticated initialization vector so that CBC decryption changes the token type and user identifier while the HMAC remains valid. This can produce an access token for an Administrator and permit full WordPress REST API access, administrator-account creation, plugin installation, and arbitrary code execution. This issue is fixed in repository version 1.8.11.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00323 25th percentileScored 2026-11-07
Fix Fixed faustjs (wpengine): 1.8.11

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
wpenginefaustjsbefore 1.8.111.8.11Patch availableCNA
  • faustjs Vendorwpengine Affected before 1.8.11 Fixed in 1.8.11 Patch available CNA

Remediation

  • Fix · CNA faustjs (wpengine) Fixed in 1.8.11

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-54239

References

  • TI-2023-06336 Better Search Replace <= 1.4.4 - Unauthenticated PHP Object Injection CVSS 3.1CRITICAL 9.8
  • TI-2024-23053 Wordpress Advanced Custom Fields Pro plugin < 6.2.10 - Contributor+ Local File Inclusion vulnerability CVSS 3.1CRITICAL 9.9
  • TI-2019-07258 The WPGraphQL 0.2.3 plugin for WordPress allows remote attackers to register a new user… CVSS 3.0CRITICAL 9.8
  • TI-2019-07259 An issue was discovered in the WPGraphQL 0.2.3 plugin for WordPress. CVSS 3.0CRITICAL 9.1
  • TI-2024-03640 Genesis Blocks <= 3.1.3 - Contributor+ Stored XSS CVSS 3.1MEDIUM 6.8
  • TI-2022-01434 WPGraphQL WooCommerce <= 0.11.0 - Unauthenticated Coupon Codes Disclosure CVSS 3.1MEDIUM 5.3
See all 32 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences