Angular: Sensitive Header Leakage on Cross-Origin Redirects in Angular Service Worker
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.1, 21.2.17, and 20.3.25, an information disclosure vulnerability exists in the @angular/service-worker package of the Angular framework. When the Service Worker fetches assets, it preserves metadata (such as headers) from the original request. However, on cross-origin redirects, the Service Worker fails to strip sensitive headers, violating the Fetch redirect algorithm. This allows a remote attacker to obtain sensitive credentials (e.g., Authorization tokens, Proxy-Authorization credentials, or session cookies) by triggering a cross-origin redirect to an untrusted external origin. This vulnerability is fixed in 22.0.1, 21.2.17, and 20.3.25.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| angular | angular | >= 22.0.0-next.0 < 22.0.1; >= 21.0.0-next.0 < 21.2.17; >= 20.0.0-next.0 < 20.3.25; up to 19.2.25 | — | No fix listed | CNA |
| — | @angular/service-worker (npm) | 22.0.0-next.0 to before 22.0.1 | 22.0.1 | Patch available | GHSA-qxh6-94w6-9r5p |
| — | @angular/service-worker (npm) | 21.0.0-next.0 to before 21.2.17 | 21.2.17 | Patch available | GHSA-qxh6-94w6-9r5p |
| — | @angular/service-worker (npm) | 20.0.0-next.0 to before 20.3.25 | 20.3.25 | Patch available | GHSA-qxh6-94w6-9r5p |
| — | @angular/service-worker (npm) | up to 19.2.25 | — | No fix listed | GHSA-qxh6-94w6-9r5p |
- angular Vendorangular Affected >= 22.0.0-next.0 < 22.0.1; >= 21.0.0-next.0 < 21.2.17; >= 20.0.0-next.0 < 20.3.25; up to 19.2.25 Fixed in — No fix listed CNA
- @angular/service-worker (npm) Vendor— Affected 22.0.0-next.0 to before 22.0.1 Fixed in 22.0.1 Patch available GHSA-qxh6-94w6-9r5p
- @angular/service-worker (npm) Vendor— Affected 21.0.0-next.0 to before 21.2.17 Fixed in 21.2.17 Patch available GHSA-qxh6-94w6-9r5p
- @angular/service-worker (npm) Vendor— Affected 20.0.0-next.0 to before 20.3.25 Fixed in 20.3.25 Patch available GHSA-qxh6-94w6-9r5p
- @angular/service-worker (npm) Vendor— Affected up to 19.2.25 Fixed in — No fix listed GHSA-qxh6-94w6-9r5p
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:angular:angular:*:*:*:*:*:node.js:*:* | up to 19.2.25; 20.0.0 to before 20.3.25; 21.0.0 to before 21.2.17; 22.0.0 to before 22.0.1 | Vulnerable | angular |
- cpe:2.3:a:angular:angular:*:*:*:*:*:node.js:*:* Versions up to 19.2.25; 20.0.0 to before 20.3.25; 21.0.0 to before 21.2.17; 22.0.0 to before 22.0.1 Vulnerable ·angular
Remediation
- Fix · GHSA-qxh6-94w6-9r5p @angular/service-worker (npm) Fixed in 22.0.1 Advisory →
- Fix · GHSA-qxh6-94w6-9r5p @angular/service-worker (npm) Fixed in 21.2.17 Advisory →
- Fix · GHSA-qxh6-94w6-9r5p @angular/service-worker (npm) Fixed in 20.3.25 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-54264
- 2026-10-03 Alias added: GHSA-qxh6-94w6-9r5p
References
Patch 2
Advisory 2
More Angular vulnerabilities
- TI-2026-60076 Angular: SSRF and Cross-Origin Credential Disclosure via URL Resolution Discrepancy in SSR CVSS 4.0HIGH 8.6
- TI-2026-60080 Angular: SSR XSS via Unescaped <template> Content Across DocumentFragment Boundaries in Fallback Raw-Content Elements CVSS 4.0HIGH 8.6
- TI-2026-60078 Angular: SSR XSS via Unescaped Processing Instruction (<?...?>) Nodes in Fallback Raw-Content Elements CVSS 4.0HIGH 8.6
- TI-2025-37971 A reflected cross-site scripting (XSS) vulnerability in CKeditor v46.1.0 & Angular… CVSS 3.1MEDIUM 5.4
- TI-2026-36931 Angular: URL Parser Differential in @angular/platform-server leading to SSRF Allowlist Bypass CVSS 4.0HIGH 8.8
- TI-2026-34131 Angular: SSRF via Hostname Hijacking in @angular/platform-server CVSS 4.0HIGH 8.8
Sources
- CVE-2026-54264 · CVE Program
- CVE-2026-54264 · NVD
- FIRST EPSS
- GHSA-qxh6-94w6-9r5p · GitHub Advisory Database · CC BY 4.0
- CVE-2026-54264 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences