LibreNMS: Remote Code Execution by Signal Alert Transportation Module
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-77.
Summary
LibreNMS is a network monitoring system. In versions from 21.6.0 up to 26.5.0, the Signal alert transport is vulnerable to command injection because the signal-cli path and the Recipient field of an alert transport entry are insufficiently escaped before being passed to an exec call. An authenticated administrator can craft a transport entry whose Recipient contains shell metacharacters and whose path points to the bundled composer_wrapper.php script, which itself passes attacker-controlled input to further unsafe exec calls. By chaining these calls, the administrator can execute arbitrary operating-system commands on the LibreNMS host. This issue is fixed in version 26.5.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| librenms | librenms | 21.6.0 to before 26.5.0 | 26.5.0 | Patch available | CNA |
| — | librenms/librenms (Packagist) | 21.6.0 to before 26.5.0 | 26.5.0 | Patch available | GHSA-c9fv-cgmm-2wg7 |
- librenms Vendorlibrenms Affected 21.6.0 to before 26.5.0 Fixed in 26.5.0 Patch available CNA
- librenms/librenms (Packagist) Vendor— Affected 21.6.0 to before 26.5.0 Fixed in 26.5.0 Patch available GHSA-c9fv-cgmm-2wg7
Remediation
- Fix · CNA librenms (librenms) Fixed in 26.5.0
- Fix · GHSA-c9fv-cgmm-2wg7 librenms/librenms (Packagist) Fixed in 26.5.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-55182
- 2026-10-03 Alias added: GHSA-c9fv-cgmm-2wg7
References
More librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-71173 LDAP filter injection in LibreNMS allows authentication bypass CVSS 4.0CRITICAL 9.2
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2026-57885 LibreNMS before 26.7.0 Stored XSS via Oxidized API CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2026-57886 LibreNMS before 26.5.0 Remote Code Execution via AboutController CVSS 4.0HIGH 8.7
Sources
- CVE-2026-55182 · CVE Program
- CVE-2026-55182 · NVD
- FIRST EPSS
- GHSA-c9fv-cgmm-2wg7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences