Read the docs
TI-2026-40092 Aliases CVE-2026-55547GHSA-cvw4-55pp-3hfq

Improper authorization in yamcs

Priority MEDIUM 53CWE-285Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-285.

Summary

Yamcs is a mission control framework. Prior to 5.12.8 and 5.13.2, Yamcs omits SystemPrivilege.ControlAccess checks from IamApi.listRoles, IamApi.getRole, and IamApi.listPrivileges in yamcs-core/src/main/java/org/yamcs/http/api/IamApi.java. Any authenticated account can call GET /api/roles, GET /api/roles/{name}, and GET /api/privileges to enumerate available system privileges and configured role mappings. The disclosure reveals security configuration that can support targeted privilege-escalation attempts. This issue is fixed in versions 5.12.8 and 5.13.2.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00342 27th percentileScored 2026-11-07
Fix Fixed yamcs (yamcs): 5.12.8, 5.13.2org.yamcs:yamcs-core (Maven): 5.13.2, 5.12.8

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
yamcsyamcsbefore 5.12.8; 5.13.0 to before 5.13.25.12.8, 5.13.2Patch availableCNA
—org.yamcs:yamcs-core (Maven)5.13.0 to before 5.13.25.13.2Patch availableGHSA-cvw4-55pp-3hfq
—org.yamcs:yamcs-core (Maven)before 5.12.85.12.8Patch availableGHSA-cvw4-55pp-3hfq
  • yamcs Vendoryamcs Affected before 5.12.8; 5.13.0 to before 5.13.2 Fixed in 5.12.8, 5.13.2 Patch available CNA
  • org.yamcs:yamcs-core (Maven) Vendor— Affected 5.13.0 to before 5.13.2 Fixed in 5.13.2 Patch available GHSA-cvw4-55pp-3hfq
  • org.yamcs:yamcs-core (Maven) Vendor— Affected before 5.12.8 Fixed in 5.12.8 Patch available GHSA-cvw4-55pp-3hfq

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:spaceapplications:yamcs:*:*:*:*:*:*:*:*——yamcs
  • cpe:2.3:a:spaceapplications:yamcs:*:*:*:*:*:*:*:* Versions — — ·yamcs

Remediation

  • Fix · CNA yamcs (yamcs) Fixed in 5.12.8, 5.13.2
  • Fix · GHSA-cvw4-55pp-3hfq org.yamcs:yamcs-core (Maven) Fixed in 5.13.2 Advisory →
  • Fix · GHSA-cvw4-55pp-3hfq org.yamcs:yamcs-core (Maven) Fixed in 5.12.8 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-55547
  2. 2026-10-03 Alias added: GHSA-cvw4-55pp-3hfq

References

  • TI-2026-40103 Yamcs: Remote Code Execution via instance-template argument YAML injection (createInstance) CVSS 3.1CRITICAL 9.8
  • TI-2026-34240 Yamcs: Remote Code Execution via Mission Database algorithm override CVSS 3.1CRITICAL 9.8
  • TI-2026-32507 Yamcs: No Rate Limiting on Authentication Endpoint CVSS 3.1CRITICAL 9.8
  • TI-2026-40106 Yamcs: Authenticated remote code execution via unescaped StreamSQL `LIKE` pattern compiled by Janino (`LikeExpression`) CVSS 3.1CRITICAL 9.9
  • TI-2026-40057 Yamcs: Authenticated RCE via StreamSQL aggregate-compiler column-name injection in Yamcs `executeSql` CVSS 3.1CRITICAL 9.1
  • TI-2026-34277 Yamcs: Authenticated Remote Code Execution (RCE) via Jython Algorithm Code Injection CVSS 3.1CRITICAL 9.1
See all 23 →

Sources