Symfony: Path Traversal in symfony/ux-toolkit Allows Arbitrary File Write and Read via Crafted Recipe Manifest
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Symfony UX is a JavaScript ecosystem for Symfony. From 2.32.0 before 2.36.1 and from 3.0.0 before 3.2.0, the ux:install console command installs files from a recipe kit by copying paths listed in a copy-files map, and because Path::isRelative() accepts paths like ../../../etc, a crafted or compromised kit can write attacker-controlled content to arbitrary locations or read local files outside the recipe directory. This issue is fixed in versions 2.36.1 and 3.2.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| symfony | ux | 2.32.0 to before 2.36.1; 3.0.0 to before 3.2.0 | 2.36.1, 3.2.0 | Patch available | CNA |
| — | symfony/ux-toolkit (Packagist) | 2.32.0 to before 2.36.1 | 2.36.1 | Patch available | GHSA-p9xj-fpr2-jf2q |
| — | symfony/ux-toolkit (Packagist) | 3.0.0 to before 3.2.0 | 3.2.0 | Patch available | GHSA-p9xj-fpr2-jf2q |
- ux Vendorsymfony Affected 2.32.0 to before 2.36.1; 3.0.0 to before 3.2.0 Fixed in 2.36.1, 3.2.0 Patch available CNA
- symfony/ux-toolkit (Packagist) Vendor— Affected 2.32.0 to before 2.36.1 Fixed in 2.36.1 Patch available GHSA-p9xj-fpr2-jf2q
- symfony/ux-toolkit (Packagist) Vendor— Affected 3.0.0 to before 3.2.0 Fixed in 3.2.0 Patch available GHSA-p9xj-fpr2-jf2q
Remediation
- Fix · CNA ux (symfony) Fixed in 2.36.1, 3.2.0
- Fix · GHSA-p9xj-fpr2-jf2q symfony/ux-toolkit (Packagist) Fixed in 2.36.1 Advisory →
- Fix · GHSA-p9xj-fpr2-jf2q symfony/ux-toolkit (Packagist) Fixed in 3.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-55878
- 2026-10-03 Alias added: GHSA-p9xj-fpr2-jf2q
References
Other 6
- https://github.com/symfony/ux/security/advisories/GHSA-p9xj-fpr2-jf2q
- https://github.com/symfony/ux/commit/7b4ddf3764bf269a1b5fde5bf03c4bce568694e4
- https://github.com/symfony/ux/releases/tag/v2.36.1
- https://github.com/symfony/ux/releases/tag/v3.2.0
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/ux-toolkit/CVE-2026-55878.yaml
- https://github.com/symfony/ux
More symfony vulnerabilities
- TI-2024-33775 Ability to change environment from query in symfony/runtime CVSS 3.1HIGH 7.3
- TI-2026-34283 Twig: The `spaceless` filter implicitly marks its output as safe CVSS 4.0MEDIUM 5.1
- TI-2022-07667 Code injection in Twig CVSS 3.1CRITICAL 9.8
- TI-2018-10028 Twig before 2.4.4 allows Server-Side Template Injection (SSTI) via the search search_key… CVSS 3.0CRITICAL 9.8
- TI-2026-35851 Incorrect authorization in symfony CVSS 4.0HIGH 8.7
- TI-2026-35264 Improper input validation in symfony CVSS 4.0HIGH 8.3
Sources
- CVE-2026-55878 · CVE Program
- CVE-2026-55878 · NVD
- FIRST EPSS
- GHSA-p9xj-fpr2-jf2q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences