pfSense Plus < 26.07 / CE < 2.9.0 Stored XSS via status_monitoring.php
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
pfSense Plus before 26.07 and CE before 2.9.0 allow authenticated users with the Status: Monitoring privilege to inject arbitrary JavaScript via graph configuration parameters in /status_monitoring.php. Multiple POST parameters including graph-left, graph-right, time-period, resolution, start-date, end-date, start-time, end-time, graph-type, invert, and refresh-interval are concatenated and written to the global pfSense XML configuration without sanitization, then echoed unsanitized into a JavaScript string context on page render. Because the setting is stored in the global configuration, the payload executes in the browser of every user who visits the Status: Monitoring page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA pfSense Plus (Netgate) Fixed in 26.07
- Fix · CNA pfSense CE (Netgate) Fixed in 2.9.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Netgate pfSense CE, pfSense Plus 2.9.0, 26.07
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2026-40506 pfSense Plus < 26.07 / CE < 2.9.0 Stored XSS via firewall_schedule_edit.phpPriority LOW 25
- TI-2026-40505 pfSense Plus < 26.07 / CE < 2.9.0 Stored XSS via firewall_rules_edit.phpPriority LOW 25
Timeline
- 2026-10-02 Threatist record created from CVE-2026-56126
- 2026-10-03 Alias added: GHSA-2356-p4rp-xj6q
References
Patch 1
More Netgate vulnerabilities
- TI-2022-13704 pfSense pfBlockerNG through 2.1.4_26 allows remote attackers to execute arbitrary OS… CVSS 3.1CRITICAL 9.8
- TI-2023-12003 A command injection vulnerability in the function restore_rrddata() of Netgate pfSense… CVSS 3.1HIGH 8.8
- TI-2024-31010 A cross-site scripting (XSS) vulnerability in pfsense v2.5.2 allows attackers to execute… CVSS 3.1CRITICAL 9.3
- TI-2023-11923 Improper restriction of excessive authentication attempts in the SSHGuard component of… CVSS 3.1CRITICAL 9.8
- TI-2023-26046 An issue in Netgate pfSense Plus v.23.05.1 and before and pfSense CE v.2.7.0 allows a… CVSS 3.1HIGH 8.8
- TI-2023-22567 An issue in Netgate pfSense v.2.7.0 allows a remote attacker to execute arbitrary code… CVSS 3.1HIGH 8.8
Sources
- CVE-2026-56126 · CVE Program
- CVE-2026-56126 · NVD
- FIRST EPSS
- GHSA-2356-p4rp-xj6q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences