Read the docs
TI-2026-40505 Aliases CVE-2026-56127GHSA-3c8g-23wp-3mx8

pfSense Plus < 26.07 / CE < 2.9.0 Stored XSS via firewall_rules_edit.php

Priority LOW 25CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Passive
Attack complexity
Low
Attack requirements
None
Impact type
Cross-site scripting
Confidentiality · integrity · availability
None · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

pfSense Plus before 26.07 and CE before 2.9.0 allow authenticated users with the Firewall: Rules: Edit privilege to inject arbitrary JavaScript via the descr parameter in /firewall_rules_edit.php. The firewall rule description is stored in the pfSense XML configuration with only backslash-escaping applied and no HTML sanitization, then rendered without encoding in the firewall log table in /status_logs_filter.php. The payload executes in the browser of any user with the Status: Logs: Firewall privilege who views the affected log entries.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01052 64th percentileScored 2026-11-07
Fix Fixed pfSense Plus (Netgate): 26.07pfSense CE (Netgate): 2.9.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
NetgatepfSense Plusbefore 26.0726.07Patch availableCNA
NetgatepfSense CEbefore 2.9.02.9.0Patch availableCNA
  • pfSense Plus VendorNetgate Affected before 26.07 Fixed in 26.07 Patch available CNA
  • pfSense CE VendorNetgate Affected before 2.9.0 Fixed in 2.9.0 Patch available CNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:pfsense:pfsense:*:*:*:*:*:*:*:*——pfSense
  • cpe:2.3:a:pfsense:pfsense:*:*:*:*:*:*:*:* Versions — — ·pfSense

Remediation

  • Fix · CNA pfSense Plus (Netgate) Fixed in 26.07
  • Fix · CNA pfSense CE (Netgate) Fixed in 2.9.0

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Netgate pfSense CE, pfSense Plus 2.9.0, 26.07

    3 records Highest priority Priority LOW 3 LOW

    Other records, highest priority first

    • TI-2026-40506 pfSense Plus < 26.07 / CE < 2.9.0 Stored XSS via firewall_schedule_edit.phpPriority LOW 25
    • TI-2026-40504 pfSense Plus < 26.07 / CE < 2.9.0 Stored XSS via status_monitoring.phpPriority LOW 25

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-56127
  2. 2026-10-03 Alias added: GHSA-3c8g-23wp-3mx8

References

  • TI-2022-13704 pfSense pfBlockerNG through 2.1.4_26 allows remote attackers to execute arbitrary OS… CVSS 3.1CRITICAL 9.8
  • TI-2023-12003 A command injection vulnerability in the function restore_rrddata() of Netgate pfSense… CVSS 3.1HIGH 8.8
  • TI-2024-31010 A cross-site scripting (XSS) vulnerability in pfsense v2.5.2 allows attackers to execute… CVSS 3.1CRITICAL 9.3
  • TI-2023-11923 Improper restriction of excessive authentication attempts in the SSHGuard component of… CVSS 3.1CRITICAL 9.8
  • TI-2023-26046 An issue in Netgate pfSense Plus v.23.05.1 and before and pfSense CE v.2.7.0 allows a… CVSS 3.1HIGH 8.8
  • TI-2023-22567 An issue in Netgate pfSense v.2.7.0 allows a remote attacker to execute arbitrary code… CVSS 3.1HIGH 8.8
See all 92 →

Sources