Parse Server: Denial of service via exponential-time processing of deeply nested query operators
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-407.
Summary
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.9.1-alpha.12 and 8.6.82, deeply nested $or, $and, and $nor query condition operators in the REST API or LiveQuery query handling could trigger exponential-time processing in the internal query-traversal helper and block the Node.js event loop. This issue is fixed in versions 9.9.1-alpha.12 and 8.6.82.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| parse-community | parse-server | 9.0.0-alpha.1 to before 9.9.1-alpha.12; before 8.6.82 | 9.9.1-alpha.12, 8.6.82 | Patch available | CNA |
- parse-server Vendorparse-community Affected 9.0.0-alpha.1 to before 9.9.1-alpha.12; before 8.6.82 Fixed in 9.9.1-alpha.12, 8.6.82 Patch available CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:*:*:* | — | — | parse-community |
- cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:*:*:* Versions — — ·parse-community
Remediation
- Fix · CNA parse-server (parse-community) Fixed in 9.9.1-alpha.12, 8.6.82
Timeline
- 2026-10-02 Threatist record created from CVE-2026-57480
References
Other 7
- https://github.com/parse-community/parse-server/security/advisories/GHSA-cgxm-vr2f-6fj8
- https://github.com/parse-community/parse-server/pull/10511
- https://github.com/parse-community/parse-server/pull/10512
- https://github.com/parse-community/parse-server/commit/0f5d2ad77b422dc904458254548be87397fc6e9b
- https://github.com/parse-community/parse-server/commit/1103c7a890e0455ba3dccd4bc5db17efe1789c9a
- https://github.com/parse-community/parse-server/releases/tag/8.6.82
- https://github.com/parse-community/parse-server/releases/tag/9.9.1-alpha.12
More parse-community vulnerabilities
- TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
- TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
- TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
- TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
- TI-2025-35510 parse is a package designed to parse JavaScript SDK. CVSS 3.1MEDIUM 6.5
- TI-2024-26265 ZDI-CAN-23894: Parse Server literalizeRegexPart SQL Injection Authentication Bypass Vulnerability CVSS 3.1CRITICAL 9.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences