Apache Kerby: StackOverflow on parsing deeply nested ASN1 structures
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 9 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-400.
Summary
By sending a deeply nested ASN1 structure to a Apache Kerby client or service, it's possible to trigger a StackOverFlow Exception which can lead to denial of service issues. Users are recommended to upgrade to version 2.1.2, which fixes this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Kerby | before 2.1.2 | 2.1.2 | Patch available | CNA |
| — | org.apache.kerby:kerby-asn1 (Maven) | before 2.1.2 | 2.1.2 | Patch available | GHSA-x6vc-x4v4-hjhr |
- Apache Kerby VendorApache Affected before 2.1.2 Fixed in 2.1.2 Patch available CNA
- org.apache.kerby:kerby-asn1 (Maven) Vendor— Affected before 2.1.2 Fixed in 2.1.2 Patch available GHSA-x6vc-x4v4-hjhr
Remediation
- Fix · CNA Apache Kerby (Apache Software Foundation) Fixed in 2.1.2
- Fix · GHSA-x6vc-x4v4-hjhr org.apache.kerby:kerby-asn1 (Maven) Fixed in 2.1.2 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apache Kerby 2.1.2
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-41694 Apache Kerby: Kerberos Pre-Authentication BypassPriority LOW 39
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat AMQ Clients | Affected | No fix yet: Fix deferred |
| Red Hat Build of Keycloak | Affected | No fix yet: Fix deferred |
| Red Hat Data Grid 8 | Affected | No fix yet: Fix deferred |
| Red Hat Fuse 7 | Affected | No fix yet: Fix deferred |
| Red Hat JBoss Enterprise Application Platform Expansion Pack | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift AI (RHOAI) | Affected | No fix yet: Fix deferred |
| Red Hat Single Sign-On 7 | Affected | No fix yet: Fix deferred |
| streams for Apache Kafka 2 | Affected | No fix yet: Fix deferred |
| streams for Apache Kafka 3 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-57914
- 2026-10-03 Alias added: GHSA-x6vc-x4v4-hjhr
- 2026-11-03 Fix available: Maven/org.apache.kerby:[email protected] · GHSA-x6vc-x4v4-hjhr
- 2026-11-03 CVSS score added · GHSA-x6vc-x4v4-hjhr
- 2026-11-03 Weakness changed · GHSA-x6vc-x4v4-hjhr
- 2026-11-03 6 new references · GHSA-x6vc-x4v4-hjhr
References
Advisory 2
More Apache vulnerabilities
- TI-2025-18529 Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT KEVCVSS 3.1CRITICAL 10.0
- TI-2024-30292 Apache OFBiz: Confused controller-view authorization logic (forced browsing) KEVCVSS 3.1CRITICAL 9.8
- TI-2024-26062 Apache OFBiz: Unauthenticated endpoint could allow execution of screen rendering code KEVCVSS 3.1CRITICAL 9.8
- TI-2024-21190 Apache OFBiz: Path traversal leading to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2024-18186 Apache HugeGraph-Server: Command execution in gremlin KEVCVSS 3.1CRITICAL 9.8
- TI-2023-25106 Deserialization of untrusted data in Apache ActiveMQ KEVCVSS 3.1CRITICAL 10.0
Sources
- CVE-2026-57914 · CVE Program
- CVE-2026-57914 · NVD
- FIRST EPSS
- GHSA-x6vc-x4v4-hjhr · GitHub Advisory Database · CC BY 4.0
- CVE-2026-57914 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences