Improper input validation in Apache ActiveMQ AMQP
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
Improper Input Validation vulnerability in Apache ActiveMQ AMQP, Apache ActiveMQ, Apache ActiveMQ All. A remote unauthenticated peer that can reach an exposed AMQP NIO connector can trigger denial-of-service behavior by sending a frame size value. This cause the NIO threads to die and if done rapidly enough can lead to exhaustion of the NIO thread pool denying service to other connections. This issue affects Apache ActiveMQ AMQP: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ All: before 5.19.9, from 6.0.0 before 6.2.8. Users are recommended to upgrade to version 5.19.9, 6.2.8, or 6.3.0 which fixes the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache ActiveMQ AMQP | before 5.19.9; 6.0.0 to before 6.2.8 | 5.19.9, 6.2.8 | Patch available | CNA |
| Apache | Apache ActiveMQ | before 5.19.9; 6.0.0 to before 6.2.8 | 5.19.9, 6.2.8 | Patch available | CNA |
| Apache | Apache ActiveMQ All | before 5.19.9; 6.0.0 to before 6.2.8 | 5.19.9, 6.2.8 | Patch available | CNA |
- Apache ActiveMQ AMQP VendorApache Affected before 5.19.9; 6.0.0 to before 6.2.8 Fixed in 5.19.9, 6.2.8 Patch available CNA
- Apache ActiveMQ VendorApache Affected before 5.19.9; 6.0.0 to before 6.2.8 Fixed in 5.19.9, 6.2.8 Patch available CNA
- Apache ActiveMQ All VendorApache Affected before 5.19.9; 6.0.0 to before 6.2.8 Fixed in 5.19.9, 6.2.8 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:* | before 5.19.9; 6.0.0 to before 6.2.8 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq_all:*:*:*:*:*:*:*:* | before 5.19.9; 6.0.0 to before 6.2.8 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq_amqp:*:*:*:*:*:*:*:* | before 5.19.9; 6.0.0 to before 6.2.8 | Vulnerable | Apache |
- cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:* Versions before 5.19.9; 6.0.0 to before 6.2.8 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq_all:*:*:*:*:*:*:*:* Versions before 5.19.9; 6.0.0 to before 6.2.8 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq_amqp:*:*:*:*:*:*:*:* Versions before 5.19.9; 6.0.0 to before 6.2.8 Vulnerable ·Apache
Remediation
- Fix · CNA Apache ActiveMQ AMQP (Apache Software Foundation) Fixed in 5.19.9, 6.2.8
- Fix · CNA Apache ActiveMQ (Apache Software Foundation) Fixed in 5.19.9, 6.2.8
- Fix · CNA Apache ActiveMQ All (Apache Software Foundation) Fixed in 5.19.9, 6.2.8
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apache ActiveMQ, Apache ActiveMQ All 5.19.9, 6.2.8
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2026-44077 Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Authorization bypass via temporary composite destinationsPriority LOW 29
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-59878
- 2026-10-03 Alias added: GHSA-4mq2-fjvq-8232
- 2026-11-06 Affected versions changed · Red Hat
- 2026-11-06 CVSS score added · Red Hat
References
More Apache Activemq vulnerabilities
- TI-2023-25106 Deserialization of untrusted data in Apache ActiveMQ KEVCVSS 3.1CRITICAL 10.0
- TI-2016-02587 The Fileserver web application in Apache ActiveMQ 5.x before 5.14.0 allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-26494 Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Authenticated users could perform RCE via Jolokia MBeans KEVCVSS 3.1HIGH 8.8
- TI-2013-05951 Xstream API versions up to 1.4.6 and version 1.4.10, if the security framework has not… CVSS 3.1CRITICAL 9.8
- TI-2021-04451 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.1
- TI-2021-04446 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-59878 · CVE Program
- CVE-2026-59878 · NVD
- FIRST EPSS
- GHSA-4mq2-fjvq-8232 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-59878 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences