vBulletin < 6.2.2 Eval Injection RCE via vb5/template/runtime.php
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-95.
Summary
vBulletin 5.x through 5.7.5 and 6.x through 6.2.1 contains an eval injection vulnerability in the vB5_Template_Runtime::runMaths() method within the template runtime that allows unauthenticated remote attackers to execute arbitrary PHP code by supplying crafted input through the pagenav[pagenumber] parameter. Attackers can exploit the insufficiently restrictive regex filter by using phpfuck-style encoding with permitted characters to inject and execute arbitrary PHP code via the unauthenticated ajax/render template route without any authentication.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA vBulletin (vBulletin) Fixed in 6.2.2
Timeline
- 2026-10-02 Threatist record created from CVE-2026-61511
- 2026-10-03 Alias added: GHSA-43hg-f3wj-j2m6
- 2026-10-14 CISA SSVC decision points changed
- 2026-10-14 Priority changed: MEDIUM → HIGH
- 2026-11-03 CISA SSVC decision points changed
References
More vBulletin vulnerabilities
- TI-2020-13248 vBulletin 5.5.4 through 5.6.2 allows remote command execution via crafted subWidgets data… KEVCVSS 3.1CRITICAL 9.8
- TI-2019-12540 vBulletin 5.x through 5.5.4 allows remote command execution via the widgetConfig[code]… KEVCVSS 3.1CRITICAL 9.8
- TI-2025-31014 vBulletin 5.0.0 through 5.7.5 and 6.0.0 through 6.0.3 allows unauthenticated users to… CVSS 3.1CRITICAL 10.0
- TI-2020-10114 vBulletin before 5.5.6pl1, 5.6.0 before 5.6.0pl1, and 5.6.1 before 5.6.1pl1 has incorrect access control. CVSS 3.1CRITICAL 9.8
- TI-2023-10600 vBulletin before 5.6.9 PL1 allows an unauthenticated remote attacker to execute arbitrary… CVSS 3.1CRITICAL 9.8
- TI-2016-05317 SQL injection vulnerability in forumrunner/includes/moderation.php in vBulletin before… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2026-61511 · CVE Program
- CVE-2026-61511 · NVD
- FIRST EPSS
- GHSA-43hg-f3wj-j2m6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences