Grav before 2.0.9 Remote Code Execution via FlexDirectory
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
Grav versions >= 1.7.0 and before 2.0.9 contain a remote code execution vulnerability. FlexDirectory::dynamicDataField() resolves blueprint data-*@: directives by calling call_user_func_array() on attacker-influenced input, validating only that the target is callable (is_callable()) without restricting dangerous functions such as exec, system, passthru, or shell_exec. Because FlexDirectory registers this handler for every Flex directory, it bypasses the validation added to Blueprint::dynamicData() in 2.0.7 (GHSA-fj2p-qj2f-74v5). Any authenticated user with create or update permission on any Flex-based directory (Flex Users, Flex Pages, Flex Objects, or custom Flex types) can execute arbitrary shell commands on the server.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| getgrav | grav | 1.7.0 to before 2.0.9 | 2.0.9 | Patch available | CNA |
| — | getgrav/grav (Packagist) | 1.7.0 to before 2.0.9 | 2.0.9 | Patch available | GHSA-c4wf-2xxc-68qm |
- grav Vendorgetgrav Affected 1.7.0 to before 2.0.9 Fixed in 2.0.9 Patch available CNA
- getgrav/grav (Packagist) Vendor— Affected 1.7.0 to before 2.0.9 Fixed in 2.0.9 Patch available GHSA-c4wf-2xxc-68qm
Remediation
- Fix · CNA grav (getgrav) Fixed in 2.0.9
- Fix · GHSA-c4wf-2xxc-68qm getgrav/grav (Packagist) Fixed in 2.0.9 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-65608
- 2026-10-03 Alias added: GHSA-c4wf-2xxc-68qm
References
More getgrav vulnerabilities
- TI-2026-30893 Grav: Privilege Escalation via Missing Server-Side Validation of groups/access CVSS 3.1CRITICAL 9.4
- TI-2025-28971 Cross Site Scripting vulnerability in grav v.1.7.48 and before allows an attacker to… CVSS 3.1CRITICAL 9.8
- TI-2021-04523 Unauthenticated Arbitrary YAML Write/Update leads to Code Execution CVSS 3.1CRITICAL 9.8
- TI-2026-50940 Grav CMS before 2.0.16 Origin Validation Bypass via Referer CVSS 4.0CRITICAL 9.3
- TI-2026-46446 Grav before 2.0.7 Remote Code Execution via Blueprint dynamicData CVSS 4.0CRITICAL 9.3
- TI-2021-22428 GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2) CVSS 4.0CRITICAL 9.3
Sources
- CVE-2026-65608 · CVE Program
- CVE-2026-65608 · NVD
- FIRST EPSS
- GHSA-c4wf-2xxc-68qm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences