Illustrator | Improper Input Validation (CWE-20)
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Illustrator is affected by an Improper Input Validation vulnerability that could result in arbitrary code execution in the context of the current user. An attacker could exploit this vulnerability to execute arbitrary code. Exploitation of this issue requires user interaction in that a victim must open a malicious file. Scope is changed.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Illustrator Desktop 2026 (Adobe) Fixed in 30.8
- Fix · CNA Illustrator Desktop 2025 (Adobe) Fixed in 29.8.11
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Adobe Illustrator Desktop 2025, Illustrator Desktop 2026 — helpx.adobe.com/security/products/illustrator/apsb26-131.ht…
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2026-53201 Illustrator | Incorrect Authorization (CWE-863)Priority LOW 39
- TI-2026-53203 Illustrator | Out-of-bounds Write (CWE-787)Priority LOW 36
Timeline
- 2026-10-02 Threatist record created from CVE-2026-75991
- 2026-10-03 Alias added: GHSA-vvfm-w99c-rvcw
References
More Adobe Illustrator vulnerabilities
- TI-2009-03980 Buffer overflow in Adobe Illustrator CS4 14.0.0, CS3 13.0.3 and earlier, and CS3 13.0.0… CVSS 2.0HIGH 9.3
- TI-2007-02283 Buffer overflow in Adobe Photoshop CS2 and CS3, Photoshop Elements 5.0, Illustrator CS3… CVSS 2.0HIGH 9.3
- TI-2007-02162 Multiple buffer overflows in Adobe Photoshop CS2 and CS3, Illustrator CS3, and GoLive 9… CVSS 2.0HIGH 9.3
- TI-2012-00719 Adobe Illustrator before CS6 allows attackers to execute arbitrary code or cause a denial… CVSS 2.0HIGH 10.0
- TI-2010-03013 Untrusted search path vulnerability in Adobe Illustrator CS4 14.0.0, CS5 15.0.1 and… CVSS 2.0HIGH 9.3
- TI-2009-03749 Buffer overflow in Adobe Illustrator CS3 13.0.3 and earlier and Illustrator CS4 14.0.0… CVSS 2.0HIGH 10.0
Sources
- CVE-2026-75991 · CVE Program
- CVE-2026-75991 · NVD
- FIRST EPSS
- GHSA-vvfm-w99c-rvcw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences