Memory leak in strongSwan
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-401.
Summary
strongSwan 5.0.2 through 6.0.7 allows PKCS#7 certificate enumeration in the openssl plugin that leads to a lack of release of memory after its effective lifetime.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| strongSwan | strongSwan | 5.0.2 to before 6.1.0 | 6.1.0 | Patch available | CNA |
- strongSwan VendorstrongSwan Affected 5.0.2 to before 6.1.0 Fixed in 6.1.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:strongswan:strongswan:*:*:*:*:*:*:*:* | 5.0.2 to before 6.1.0 | Vulnerable | strongSwan |
- cpe:2.3:a:strongswan:strongswan:*:*:*:*:*:*:*:* Versions 5.0.2 to before 6.1.0 Vulnerable ·strongSwan
Remediation
- Fix · CNA strongSwan (strongSwan) Fixed in 6.1.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
strongSwan 6.1.0
11 records Highest priority Priority LOW 11 LOW
Other records, highest priority first
- TI-2026-54334 Infinite loop in strongSwanPriority LOW 39
- TI-2026-54332 strongSwan 4.2.0 through 6.0.7 has a NULL pointer dereference in the x509 plugin's attribute certificate parser.Priority LOW 39
- TI-2026-54335 libcharon in strongSwan 6.0.0 through 6.0.7 has a use-after-free in IKEv2 rekeying collision handling.Priority LOW 35
Timeline
- 2026-10-02 Threatist record created from CVE-2026-78124
- 2026-10-03 Alias added: GHSA-693g-ppp7-3j2h
References
More Strongswan vulnerabilities
- TI-2023-22300 strongSwan before 5.9.12 has a buffer overflow and possible unauthenticated remote code… CVSS 3.1CRITICAL 9.8
- TI-2015-03374 strongSwan 5.2.2 and 5.3.0 allows remote attackers to cause a denial of service (daemon… CVSS 3.0CRITICAL 9.8
- TI-2004-00531 FreeS/WAN 1.x and 2.x, and other related products including superfreeswan 1.x, openswan… CVSS 2.0HIGH 10.0
- TI-2023-11610 strongSwan 5.9.8 and 5.9.9 potentially allows remote code execution because it uses a… CVSS 3.1CRITICAL 9.8
- TI-2021-20414 In strongSwan before 5.9.5, a malicious responder can send an EAP-Success message too… CVSS 3.1CRITICAL 9.1
- TI-2017-08240 The gmp plugin in strongSwan before 5.6.0 allows remote attackers to cause a denial of… CVSS 3.1HIGH 7.5
Sources
- CVE-2026-78124 · CVE Program
- CVE-2026-78124 · NVD
- FIRST EPSS
- GHSA-693g-ppp7-3j2h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences