Uncontrolled Resource Consumption in MongoDB Server JSON Pointer Parser Leads to Denial of Service
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-770.
Summary
A security issue exists in MongoDB server's JSON Pointer parser used during $jsonSchema query filter processing. When a find command includes a specially crafted $jsonSchema filter field, the parser processes the input without enforcing adequate limits on iteration count or total allocation size, resulting in significant memory amplification. Under concurrent request load, the cumulative memory consumption can exhaust available heap memory, causing the server's out-of-memory handler to terminate the mongod process and deny service to all connected clients.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| MongoDB | MongoDB Server | 8.3.0 to before 8.3.9; 8.0.0 to before 8.0.30; 7.0.0 to before 7.0.41 | 8.3.9, 8.0.30, 7.0.41 | Patch available | CNA |
- MongoDB Server VendorMongoDB Affected 8.3.0 to before 8.3.9; 8.0.0 to before 8.0.30; 7.0.0 to before 7.0.41 Fixed in 8.3.9, 8.0.30, 7.0.41 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mongodb:mongodb:*:*:*:*:*:*:*:* | 7.0.0 to before 7.0.41; 8.0.0 to before 8.0.30; 8.2.0 – 8.2.12; 8.3.0 to before 8.3.9 | Vulnerable | MongoDB |
| cpe:2.3:a:mongodb:mongodb:9.0.0:alpha0:*:*:-:-:*:* | 9.0.0 alpha0 | Vulnerable | MongoDB |
| cpe:2.3:a:mongodb:mongodb:9.0.0:alpha1:*:*:-:-:*:* | 9.0.0 alpha1 | Vulnerable | MongoDB |
| cpe:2.3:a:mongodb:mongodb:9.1.0:alpha0:*:*:-:-:*:* | 9.1.0 alpha0 | Vulnerable | MongoDB |
- cpe:2.3:a:mongodb:mongodb:*:*:*:*:*:*:*:* Versions 7.0.0 to before 7.0.41; 8.0.0 to before 8.0.30; 8.2.0 – 8.2.12; 8.3.0 to before 8.3.9 Vulnerable ·MongoDB
- cpe:2.3:a:mongodb:mongodb:9.0.0:alpha0:*:*:-:-:*:* Versions 9.0.0 alpha0 Vulnerable ·MongoDB
- cpe:2.3:a:mongodb:mongodb:9.0.0:alpha1:*:*:-:-:*:* Versions 9.0.0 alpha1 Vulnerable ·MongoDB
- cpe:2.3:a:mongodb:mongodb:9.1.0:alpha0:*:*:-:-:*:* Versions 9.1.0 alpha0 Vulnerable ·MongoDB
Remediation
- Fix · CNA MongoDB Server (MongoDB) Fixed in 8.3.9, 8.0.30, 7.0.41
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
MongoDB Server 7.0.41, 8.0.30, 8.3.9
16 records Highest priority Priority MEDIUM 3 MEDIUM, 13 LOW
Other records, highest priority first
- TI-2026-56639 Uncontrolled Resource Consumption in MongoDB Sharded Cluster Router Allows Unauthenticated Denial of ServicePriority MEDIUM 44
- TI-2026-56628 Reachable assertion in MongoDB ServerPriority MEDIUM 44
- TI-2026-56631 Improper Case Sensitivity Handling in MongoDB Server Configuration Validation May Cause…Priority MEDIUM 42
Timeline
- 2026-10-02 Threatist record created from CVE-2026-82054
- 2026-10-03 Alias added: GHSA-6wc7-3wqm-rgrj
References
More Mongodb vulnerabilities
- TI-2025-13542 Zlib compressed protocol header length confusion may allow memory read KEVCVSS 4.0HIGH 8.7
- TI-2013-01669 MongoDB before 2.0.9 and 2.2.x before 2.2.4 does not properly validate requests to the… CVSS 2.0MEDIUM 6.0
- TI-2026-56639 Uncontrolled Resource Consumption in MongoDB Sharded Cluster Router Allows Unauthenticated Denial of Service CVSS 4.0HIGH 8.7
- TI-2026-56628 Reachable assertion in MongoDB Server CVSS 4.0HIGH 8.7
- TI-2026-15322 Improper Input Validation in MongoDB Aggregation Framework Allows Unauthenticated Denial of Service on mongos CVSS 4.0HIGH 8.7
- TI-2026-08537 Unbounded recursion in BSONColumn interleaved-reference causes pre-auth stack overflow CVSS 4.0HIGH 8.7
Sources
- CVE-2026-82054 · CVE Program
- CVE-2026-82054 · NVD
- FIRST EPSS
- GHSA-6wc7-3wqm-rgrj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences