PocketMine-MP before 5.39.2 Network Amplification via ActorEventPacket
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
PocketMine-MP versions before 5.39.2 contain a network amplification vulnerability in ActorEventPacket handling that allows clients to trigger consuming animations for all visible players. Attackers can send crafted ActorEventPacket messages to spam animation events to other clients and waste server CPU and memory resources.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA PocketMine-MP (pmmp) Fixed in 5.39.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
pmmp PocketMine-MP 5.39.2
3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2026-58993 PocketMine-MP before 5.39.2 Denial of Service via ModalFormResponsePacketPriority MEDIUM 64
- TI-2026-58992 PocketMine-MP before 5.39.2 Item Duplication via Despawn StatePriority LOW 28
Timeline
- 2026-10-02 Threatist record created from CVE-2026-86202
- 2026-10-03 Alias added: GHSA-5g4f-vg94-wpxh
References
Patch 1
More pmmp vulnerabilities
- TI-2026-58990 PocketMine-MP before 5.41.1 LogDoS via LoginPacket clientData CVSS 4.0HIGH 8.7
- TI-2026-58988 PocketMine-MP before 5.43.1 Denial of Service via unauthenticated login CVSS 4.0HIGH 8.7
- TI-2026-58993 PocketMine-MP before 5.39.2 Denial of Service via ModalFormResponsePacket CVSS 4.0HIGH 7.1
- TI-2024-38460 PocketMine-MP before 5.11.1 Denial of Service via LoginPacket CVSS 4.0HIGH 8.7
- TI-2023-30643 PocketMine-MP before 4.20.5 Denial of Service via LoginPacket CVSS 4.0HIGH 8.7
- TI-2023-30640 PocketMine-MP before 5.3.1 Denial of Service via LoginPacket CVSS 4.0HIGH 8.7
Sources
- CVE-2026-86202 · CVE Program
- CVE-2026-86202 · NVD
- FIRST EPSS
- GHSA-5g4f-vg94-wpxh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences