Ollama GGUF Decoder gguf.go readGGUFV1String integer overflow
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
A vulnerability was found in Ollama up to 0.31.1. This issue affects the function readGGUFV1String of the file fs/ggml/gguf.go of the component GGUF Decoder. Performing a manipulation results in integer overflow. The attack is possible to be carried out remotely. The exploit has been made public and could be used. Upgrading to version 0.31.2-rc1 is capable of addressing this issue. The patch is named 67b6a1c2d45321e0cb3c04a18073f9818de7724b. It is recommended to upgrade the affected component.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Ollama | 0.31.0; 0.31.1 | 0.31.2-rc1 | Patch available | CNA |
- Ollama Vendor— Affected 0.31.0; 0.31.1 Fixed in 0.31.2-rc1 Patch available CNA
Remediation
- Fix · CNA Ollama Fixed in 0.31.2-rc1
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-86289
- 2026-10-03 Alias added: GHSA-c2q9-58w2-gjg4
References
Sources
- CVE-2026-86289 · CVE Program
- CVE-2026-86289 · NVD
- FIRST EPSS
- GHSA-c2q9-58w2-gjg4 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-86289 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences