Renovate before 44.11.3 Credential Exfiltration via Link Header
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-601.
Summary
Renovate before 44.11.3 fails to validate Link header destinations when following GitLab server pagination, allowing malicious servers to redirect credential-bearing requests. Attackers controlling a compromised GitLab server can specify a Link header pointing to attacker-controlled infrastructure to exfiltrate authentication credentials.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| renovatebot | renovate | before 44.11.3 | 44.11.3 | Patch available | CNA |
| mend | renovate-ce | before 15.4.0 | 15.4.0 | Patch available | CNA |
| mend | renovate-ee-server | before 15.4.0 | 15.4.0 | Patch available | CNA |
| mend | renovate-ee-worker | before 15.4.0 | 15.4.0 | Patch available | CNA |
| mend | mend-renovate-ce | before 15.4.0 | 15.4.0 | Patch available | CNA |
| mend | mend-renovate-enterprise-edition | before 10.4.0 | 10.4.0 | Patch available | CNA |
- renovate Vendorrenovatebot Affected before 44.11.3 Fixed in 44.11.3 Patch available CNA
- renovate-ce Vendormend Affected before 15.4.0 Fixed in 15.4.0 Patch available CNA
- renovate-ee-server Vendormend Affected before 15.4.0 Fixed in 15.4.0 Patch available CNA
- renovate-ee-worker Vendormend Affected before 15.4.0 Fixed in 15.4.0 Patch available CNA
- mend-renovate-ce Vendormend Affected before 15.4.0 Fixed in 15.4.0 Patch available CNA
- mend-renovate-enterprise-edition Vendormend Affected before 10.4.0 Fixed in 10.4.0 Patch available CNA
Remediation
- Fix · CNA renovate (renovatebot) Fixed in 44.11.3
- Fix · CNA renovate-ce (mend) Fixed in 15.4.0
- Fix · CNA renovate-ee-server (mend) Fixed in 15.4.0
- Fix · CNA renovate-ee-worker (mend) Fixed in 15.4.0
- Fix · CNA mend-renovate-ce (mend) Fixed in 15.4.0
- Fix · CNA mend-renovate-enterprise-edition (mend) Fixed in 10.4.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
mend-renovate-ce, mend-renovate-enterprise-edition and 3 more products 10.4.0, 15.4.0
10 records Highest priority Priority MEDIUM 5 MEDIUM, 5 LOW
Other records, highest priority first
- TI-2026-60271 Renovate before 44.11.2 Credential Exfiltration via Link HeaderPriority MEDIUM 46
- TI-2026-60266 Renovate before 44.11.2 Credential Exfiltration via Link HeaderPriority MEDIUM 46
- TI-2026-60265 Renovate before 44.11.3 Credential Exfiltration via Link HeaderPriority MEDIUM 46
- Release ·
renovatebot renovate 44.11.3
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2026-60265 Renovate before 44.11.3 Credential Exfiltration via Link HeaderPriority MEDIUM 46
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-88880
- 2026-10-03 Alias added: GHSA-wqcg-39wp-gpqc
References
More renovatebot vulnerabilities
- TI-2026-53338 Renovate 39.53.0 before 40.33.0 Command Injection via gleam manager CVSS 4.0HIGH 8.4
- TI-2026-53337 Renovate 31.51.0 before 40.33.0 Command Injection via helmv3 CVSS 4.0HIGH 8.4
- TI-2026-53336 Renovate 32.135.0 before 40.33.0 Command Injection via hermit CVSS 4.0HIGH 8.4
- TI-2026-53335 Renovate 35.63.0 before 40.33.0 Command Injection via npm CVSS 4.0HIGH 8.4
- TI-2026-53333 Renovate before 42.68.5 Remote Code Execution via Gradle Wrapper CVSS 4.0HIGH 8.4
- TI-2026-60271 Renovate before 44.11.2 Credential Exfiltration via Link Header CVSS 4.0CRITICAL 9.2
Sources
- CVE-2026-88880 · CVE Program
- CVE-2026-88880 · NVD
- FIRST EPSS
- GHSA-wqcg-39wp-gpqc · GitHub Advisory Database · CC BY 4.0
- CVE-2026-88880 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences