Read the docs
TI-2026-62230 Aliases CVE-2026-92134GHSA-jv9v-4wvp-mh7g

Cross-site scripting in Jenkins Warnings Plugin

Priority LOW 37CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

Jenkins Warnings Plugin 13.10258.va_17d49a_78c3b_ and earlier does not validate the analysis results ID when a job configuration is submitted through the REST API, allowing attackers with Item/Configure permission to use a javascript: scheme URL as identifier, resulting in a stored cross-site scripting (XSS) vulnerability.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00413 35th percentileScored 2026-11-07
Fix Fixed Jenkins Warnings Plugin (Jenkins Project): 13.10223.10225.vcf001b_b_b_3a_90, 13.10259.v80f407cb_03a_e

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Warnings Plugin—13.10223.10225.vcf001b_b_b_3a_90, 13.10259.v80f407cb_03a_ePatch availableCNA
  • Jenkins Warnings Plugin VendorJenkins Affected — Fixed in 13.10223.10225.vcf001b_b_b_3a_90, 13.10259.v80f407cb_03a_e Patch available CNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:warnings:*:*:*:*:*:*:*:*——Jenkins
  • cpe:2.3:a:jenkins:warnings:*:*:*:*:*:*:*:* Versions — — ·Jenkins

Remediation

  • Fix · CNA Jenkins Warnings Plugin (Jenkins Project) Fixed in 13.10223.10225.vcf001b_b_b_3a_90, 13.10259.v80f407cb_03a_e

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-92134
  2. 2026-10-03 Alias added: GHSA-jv9v-4wvp-mh7g

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
  • TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
See all 1914 →

Sources