Read the docs
TI-2026-62231 Aliases CVE-2026-92135GHSA-29m4-vpx5-mmrm

Cross-site scripting in Jenkins Coverage Plugin

Priority LOW 37CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

Jenkins Coverage Plugin 3.3358.v9487dde48783 and earlier does not validate the coverage results ID when a job configuration is submitted through the REST API, allowing attackers with Item/Configure permission to use a javascript: scheme URL as identifier, resulting in a stored cross-site scripting (XSS) vulnerability.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00413 35th percentileScored 2026-11-07
Fix Fixed Jenkins Coverage Plugin (Jenkins Project): 3.3325.3327.v26c59e218691, 3.3361.v0626103a_67e6

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Coverage Plugin—3.3325.3327.v26c59e218691, 3.3361.v0626103a_67e6Patch availableCNA
  • Jenkins Coverage Plugin VendorJenkins Affected — Fixed in 3.3325.3327.v26c59e218691, 3.3361.v0626103a_67e6 Patch available CNA

Remediation

  • Fix · CNA Jenkins Coverage Plugin (Jenkins Project) Fixed in 3.3325.3327.v26c59e218691, 3.3361.v0626103a_67e6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-92135
  2. 2026-10-03 Alias added: GHSA-29m4-vpx5-mmrm

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
  • TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
See all 1914 →

Sources