Amplified responses in Apache Struts via BigDecimal parameters
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
Apache Struts from 2.5.14 through 2.5.33, from 6.0.0 through 6.11.0, and from 7.0.0 through 7.3.0 is affected. A request parameter bound to a BigDecimal property and rendered through the Struts tag library can produce a response far larger than the request (CWE-405). An unauthenticated remote attacker can exhaust server CPU and outbound network capacity with sustained low-volume traffic.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
Asymmetric resource consumption (amplification) vulnerability in Apache Struts. When a request parameter is bound to an arbitrary-precision decimal (java.math.BigDecimal) property that is then rendered through the Struts tag library, the framework can produce a response many orders of magnitude larger than the request, allowing an unauthenticated remote attacker to exhaust server CPU and outbound network capacity with sustained low-volume traffic. Applications that do not bind request parameters to BigDecimal properties, or never render such a property through the Struts tag library, are not affected. This issue affects Apache Struts: from 2.5.14 through 2.5.33, from 6.0.0 through 6.11.0, from 7.0.0 through 7.3.0. Users are recommended to upgrade to version 6.12.0 or 7.4.0, which fixes the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Upgrade to Apache Struts 6.12.0 or 7.4.0, which fix the issue. The sources list no fixed version for Apache Struts.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
- Red Hat Fuse 7
Timeline
- 2026-10-05 Threatist record created from CVE-2026-104712
- 2026-10-06 Alias added: GHSA-8536-jvj9-v78f
- 2026-10-06 Affected versions changed · Red Hat
- 2026-10-06 CVSS score added · Red Hat
- 2026-10-06 CVSS score added · CISA ADP
- 2026-10-06 CISA SSVC decision points changed
- 2026-10-07 Affected versions changed · Red Hat
- 2026-10-07 Priority changed: LOW → MEDIUM
- 2026-10-09 EPSS moved to the 50th–90th percentile
- 2026-10-09 Affected versions changed · Red Hat
- 2026-10-20 Affected versions changed · Red Hat
References
More Apache Struts vulnerabilities
- TI-2020-13278 Expression language injection in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-07171 Improper input validation in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2013-02013 Apache Struts 2.0.0 through 2.3.15 allows remote attackers to execute arbitrary OGNL… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-00357 The ExceptionDelegator component in Apache Struts before 2.2.3.1 interprets parameter… KEVCVSS 3.1CRITICAL 9.8
- TI-2018-08433 Improper input validation in Apache Struts KEVCVSS 3.1HIGH 8.1
Sources
- CVE-2026-104712 · CVE Program
- CVE-2026-104712 · NVD
- FIRST EPSS
- GHSA-8536-jvj9-v78f · GitHub Advisory Database · CC BY 4.0
- CVE-2026-104712 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences